ZCar Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
Those are great times you are getting out of your Z.
I think the main thing holding me back is my factory turbo so I had a few questions:

Did your upgraded turbo bolt right up or did you have to modify your exhaust manifold?

What kind of boost control are you using?

How does the turbo work on the street as far as spool up times and where did you get it? Cost?

Are you still using the factory clutch?

Thanks
Dave
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
Dave, My turbo has a T04 60-1 compressor and a stock T3 exhaust side so it does bolt right up, It's a little tight between the compressor side and the intake, but it does fit. I'm using a cheap turbonetics boost controler, manual style bleed valve. It was $90. If you can afford a nice digital one, I'd recommend it ($200-400). It spools about the same as stock since the exhasut side is the same. Boost starts around 2400 or so and is full boost (15psi) around 3000-3300. A place called Turbo RX in Phx AZ did my turbo I gave them the old one and 2 days and $490 later I had it back. I am still using the factory clutch, if I turn the boost over 15 it slips in 3rd, 4th and 5th. 15 psi or less and its ok. I've taken it to 17psi with the stock ecu, stock injectors, and a whole lot of fuel pressure (70-75psi). And it does just fine, no detonation and not leaning out acording to my air/fuel ratio monitor. Good luck! BTW those times are on the stock 205/60/15 tires!! It burns them bad in 1st and 2nd. 3rd...just a little cherp and your on your way.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top