ZCar Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
Help please !!!!!
My 82 280ZX 2+2 is rarely driven. I took it out for a limbering up - got about two houses down the street and EVERYTHING shut down EXCEPT the engine. It kept running fine.
BUT, all dash instruments, ( ALL), went off, even the tach and speedometer. (?)
I drove directly back home. Now everything works fine, EXCEPT THE POWER WINDOWS do not work.

Anyone have any advice for me.

Thanks, and God Bless

Charles
 

·
Registered
Joined
·
3,310 Posts
Power windows have a separate circuit breaker on the r/h kickpanel area.
 

·
Registered
Joined
·
2,284 Posts
Hi Charles-------------I have an '83 that does the disappearing dash trick. Sometimes it will be there upon starting and then go out with no warning as I am driving. This is not an uncommon phenomenon--I've seen dozens of posts by other ZX drivers with digital dash that have the same problem. There is supposed to be a control unit mounted close to the digital meter under the dash that can cause this, but I've never checked for it. Some day when I'm through fooling with my other Z's I'll look into it.

Roadman
 

·
Registered
Joined
·
144 Posts
Discussion Starter #5
Thanks to each of you:
-I cannot find a fuse that is identified as Pwr. Windows.
--Dash is analog. not digital
--I will check the circuit breaker at right kick panel .IS IT A RESET TYPE OR DO I REPLACE IT????
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top