ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
I have a 73 240Z.

Oh where do i start... I got in a wreck about 2 months ago and the body shop people have been putting it back together and they did not do a very good job with some of the car. OK at night my back lights on the tack sppedomoeter and all the other gauges don't work. The gagues themselvs work but the lights don't. The lights over the heater and the ac controls are lit up but the others don't work. The ampmeter is really jumping when I rev the engine so HELP. My choke light never goes off even when i am not using the choke. My speedometer does not work but bounces all over the gauge but my odometer works just fine. My ac fan which usually turns on when I turn the knob does not work so I can't get any hot air out the vents only yhe defrost. I saw the fuse was burned out so i reaplaced that and it went out right after I turned on the car I didn't even have the fan turned on. My radio which is stock DOES NOT WORK now it does not even turn on and the green light does not even turn on. All has gone to **** with my car and I know theose people will fix some of the car but I must know how to fix some of the problems.
Please people Help me fix my old car great again!!!!!!

Dustin Morris
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
Wow... all I have to say is that really sucks. I wish I could help you, but ... I dont have the knowledge to do so...

were all these problems caused by the accident?? if so why wont the insurance company deal with it and fix everything?? (or was the accidend entirely your fault??)

> I have a 73 240Z.

> Oh where do i start... I got in a wreck
> about 2 months ago and the body shop people
> have been putting it back together and they
> did not do a very good job with some of the
> car. OK at night my back lights on the tack
> sppedomoeter and all the other gauges don't
> work. The gagues themselvs work but the
> lights don't. The lights over the heater and
> the ac controls are lit up but the others
> don't work. The ampmeter is really jumping
> when I rev the engine so HELP. My choke
> light never goes off even when i am not
> using the choke. My speedometer does not
> work but bounces all over the gauge but my
> odometer works just fine. My ac fan which
> usually turns on when I turn the knob does
> not work so I can't get any hot air out the
> vents only yhe defrost. I saw the fuse was
> burned out so i reaplaced that and it went
> out right after I turned on the car I didn't
> even have the fan turned on. My radio which
> is stock DOES NOT WORK now it does not even
> turn on and the green light does not even
> turn on. All has gone to **** with my car
> and I know theose people will fix some of
> the car but I must know how to fix some of
> the problems.
> Please people Help me fix my old car great
> again!!!!!!

> Dustin Morris
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
> Wow... all I have to say is that really
> sucks. I wish I could help you, but ... I
> dont have the knowledge to do so...

> were all these problems caused by the
> accident?? if so why wont the insurance
> company deal with it and fix everything??
> (or was the accidend entirely your fault??)

Check the wiring harness connections under the dash on the passenger side. Make sure all the colors match each side. When I put my dash back in I accidentally switched the high beams (red w/ white stripe) and the alternator feed (white w/red stripe) and couldn't figure why the car wouldnt charge and turning high beams on fried my headlight switch (2 of them :< ). the Z shop told me I had a bad alternator, so I also replaced it unnecessarily.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top