ZCar Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
I'm a new to Z mechanics, hope some one will help. I recently degreased the engine of a 78 280ZX. Everything seemed to run fine after rinsing the cleaner off the motor and drying vital electronics. I replaced a few vacuum lines and put in a new Accel coil. Now when I run the engine to near WOT, it smothers out at 2,300 rmp. Anything below that and its fine. So I put the OEM coil back on, same problem. Anbody have any ideas what to check??
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
sounds like ffuel delivery problems. Check filter and pull line from fuel tank and see if any rust flows out witht he gas. Sam 75 280z, 81 280zxt
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
Norman
It sounds to me like you have water in the throttle position sensor. It faces up and if there is a crack in the connector housing the connector on the throttle body fills with water. Happened to me every time I washed the engine on my 83 ZXT until I wrapped the connector casing in electrical tape. I'm sure this is what it is.

Russel 83ZXT
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #5 ·
It is for sure is the throttle position sensor... good call Russel! Seen this before... It happens right at the RPM range your selling. Wow funny how this stuff comes back to you after awhile. Been out of the Z click for about 3 years now. Mines sitting in the garage waiting on me.
 

·
Registered
Joined
·
1,610 Posts
Happened to me Last Week!!

Norman,
Had the exact same thing happen to me a week ago on my '77 280Z. Had just had the engine detailed and it would not run over 2,500 RPM. Started and ran perfectly right up to that and then just quit until the RPM dropped back down to 2,300 and then it would be fine again. I let the car sit in the garage over the weekend and it was fine Monday morning. Just needed some time and warm weather to evaporate the water out of the TPS.
Phantom
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #7 ·
<b>Thanks Russel and everyone! You guys rock!!</b>

Hit it on the nose Russel. After letting it sit over night, the next afternoon it cured itself. Sure glad this website is here and active. Thanks again everyboby!!
You guys ROCK!!!!
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top