ZCar Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter #1
Ok I went through all of the components in the fuel system and replaced all hoses, soaked the bar, and all that stuff. Found the faulty injector and replaced it. SO now here is my BIGGEST problem....the fuel pump cycles in and out after the car has warmed up. It is brand new so I hope that isn't the problem here! Anyways it causes the car to backfire and feel like you have taken your foot off of the gas. If you release the gas pedal it takes it a minute to recover and it idles just fine. BUT you give it gas it will have power for a second then the fuel pump will slow down and the car starves for gas. (The fuel pump goes quiet for a sec then begins to make its normal noise again and the engine stabilizes). Is there a sensor that controls the fuel flow to the system?? I replaced the pressure regulator on the fuel bar it helped but still not enough. Do the oxygen sensors have anything to do with the fuel control?? Cleaned computer contacts too. Please help!!
 

·
Registered
Joined
·
62 Posts
Re: HELP! '83 280ZX brought back to life in troubl

> Ok I went through all of the components in
> the fuel system and replaced all hoses,
> soaked the bar, and all that stuff. Found
> the faulty injector and replaced it. SO now
> here is my BIGGEST problem....the fuel pump
> cycles in and out after the car has warmed
> up. It is brand new so I hope that isn't the
> problem here! Anyways it causes the car to
> backfire and feel like you have taken your
> foot off of the gas. If you release the gas
> pedal it takes it a minute to recover and it
> idles just fine. BUT you give it gas it will
> have power for a second then the fuel pump
> will slow down and the car starves for gas.
> (The fuel pump goes quiet for a sec then
> begins to make its normal noise again and
> the engine stabilizes). Is there a sensor
> that controls the fuel flow to the system??
> I replaced the pressure regulator on the
> fuel bar it helped but still not enough. Do
> the oxygen sensors have anything to do with
> the fuel control?? Cleaned computer contacts
> too. Please help!!

Hey Sean, I kinda have the same problem right now, but my car has been broken down for a long time, I have replaced a lot of parts, it is now about 2 months away from total healthy existence, but I have been under the impression with my car that this was happening because I do not have the right control unit hooked up in my car, when I get the money, I'm going to buy a new one, and also an air pressure regulator, a bad one will affect the way the car runs, it's possible that the fuel relays are bad, it really sounds like a few of the circuits in your ecu have blown, and not sending or recieving signals with the fuel pump, the ecu plays a major part in the fuel delivery, by the way my car is an 80 zx. You need to go to a Nissan dealer, tell them what year Z you have, what month it was manufactured in, and if the engine is a Californian spec or Canadian, or something like that, they will ask you, I did this, get them to tell you the part number for the oem control unit for your car, then pull the control unit out, and match up the numbers...good luck, I know EXACTLY what you are going through, your car is totally undrivable, if you do try to drive it, it's really embarassing cause your car is bucking wildly at 25 or so mph....Z-Godspeed!
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter #3
Re: HELP! '83 280ZX brought back to life in troubl

> Ok I went through all of the components in
> the fuel system and replaced all hoses,
> soaked the bar, and all that stuff. Found
> the faulty injector and replaced it. SO now
> here is my BIGGEST problem....the fuel pump
> cycles in and out after the car has warmed
> up. It is brand new so I hope that isn't the
> problem here! Anyways it causes the car to
> backfire and feel like you have taken your
> foot off of the gas. If you release the gas
> pedal it takes it a minute to recover and it
> idles just fine. BUT you give it gas it will
> have power for a second then the fuel pump
> will slow down and the car starves for gas.
> (The fuel pump goes quiet for a sec then
> begins to make its normal noise again and
> the engine stabilizes). Is there a sensor
> that controls the fuel flow to the system??
> I replaced the pressure regulator on the
> fuel bar it helped but still not enough. Do
> the oxygen sensors have anything to do with
> the fuel control?? Cleaned computer contacts
> too. Please help!!

Are you sure it's starving? I had the same symptoms due to a very over rich condition.
A bad temp sensor was replaced and voila' On the road again..

ciao, bobw
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter #4
Re: HELP! '83 280ZX brought back to life in troubl

> Ok I went through all of the components in
> the fuel system and replaced all hoses,
> soaked the bar, and all that stuff. Found
> the faulty injector and replaced it. SO now
> here is my BIGGEST problem....the fuel pump
> cycles in and out after the car has warmed
> up. It is brand new so I hope that isn't the
> problem here! Anyways it causes the car to
> backfire and feel like you have taken your
> foot off of the gas. If you release the gas
> pedal it takes it a minute to recover and it
> idles just fine. BUT you give it gas it will
> have power for a second then the fuel pump
> will slow down and the car starves for gas.
> (The fuel pump goes quiet for a sec then
> begins to make its normal noise again and
> the engine stabilizes). Is there a sensor
> that controls the fuel flow to the system??
> I replaced the pressure regulator on the
> fuel bar it helped but still not enough. Do
> the oxygen sensors have anything to do with
> the fuel control?? Cleaned computer contacts
> too. Please help!!

Are you sure it's starving? I had the same symptoms due to a very over rich condition.
A bad temp sensor was replaced and voila' On the road again..

ciao, bobw
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top