ZCar Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,
I am restoring my 1980 280zx, I have no heat, blower works but no heat. I pulled the dash, could not find the heater core. Can anyone help.
20200502_092004.jpg
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thank you for your response. Heater core is good. I believe I have vacuum issues. Any suggestions where to start from
 

·
Banned
Joined
·
17 Posts
Check the hose nipples on the firewall and you'll see what plastic box(es) to remove. according to SPEZIAL and kindly check the down pipe as well then put it off and On again you will see the result ......
 

·
Registered
Joined
·
907 Posts
Check the hose nipples on the firewall and you'll see what plastic box(es) to remove. according to SPEZIAL and kindly check the down pipe as well then put it off and On again you will see the result ......
The first sentence is clear, but you will do better to check a service manual because there is a sequence of disassembly to get at the core.

The rest of the post above makes no sense.
 

·
Registered
Joined
·
907 Posts
How did you start restoring my 1980 280zx?
Are you REALLY too lazy to start a thread on that topic? And why are you asking a question with no specifics that can't be answered in any detail?

I recommend doing a lot of reading, checking online references and then asking a well informed question after you are able to provide specific details on the vehicle, the condition, and your goals in a restoration.
 
1 - 9 of 9 Posts
Top