ZCar Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
My gas guage started acting up, reading 1/2 full when the tank is full, things like that. My first thought was to replace the connectors that lead to the sensor. The problem is, the terminals aren't regular wire terminals, they look like nail heads sticking out from the gas tank! The connectors fit very loosely around those. Where can I find connectors that will work here?

-Brian
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
> My gas guage started acting up, reading 1/2
> full when the tank is full, things like
> that. My first thought was to replace the
> connectors that lead to the sensor. The
> problem is, the terminals aren't regular
> wire terminals, they look like nail heads
> sticking out from the gas tank! The
> connectors fit very loosely around those.
> Where can I find connectors that will work
> here?

> -Brian
You might try giving your original connectors a good cleaning, and a bit of a crimp...might put a dab of RTV or sealant of some kind around them to keep the elements out. If they're shot you should be able to use some small bullet connectors. Chances are the resistor on the sending unit is on it's way out,you might try pulling it out of the tank and taking some ohm readings as you move it up and down, it should gradually and evenly increase or decrease as you move the float, if it fluctuates or sticks on a value ,it's history. I don't think the resistor unit is replaceable alone.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top