ZCar Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 84 300zx Turbo (wich doent work) 5 speed. Im having trouble with my fuel pump and fuel pressure regulator. When you put the key in the run position you here the fuel pump come on and it brings the fuel pressure up to where it is supposed to be. Now while driving the car it will out of the blue just die.

But now when you put the key in the run position you can here the fuel pump sounds a lot different. It sounds kind of like a car turning over and the fuel pump never turns off. When I open the hood, while the key is in the run position, and the fuel pump is running I can here a noise from the fuel pressure regulator.

I think that the regulator is sending the fuel back to the fuel tank and it is not building pressure. That I think is why the fuel pump never turns off.
3 days ago a I went to the dealer and told about it and he said it could be up to 4 things that could probably be causing it, of course he didnt share what those things could have been. So I thought I would ask the forum.

Hopefully some one will have some info for me.
Thanks for your help
Carl
 

·
Registered
Joined
·
782 Posts
To check the regulator remove the vacuum line off the top and rev it up alittle bit it and see if fuel comes out if so you need a new one, that is if you can get it to start. If its not that you may need to change the pump or check the relay and make sure the pump is getting 12 volts.
 

·
Registered
Joined
·
7,924 Posts
actually I know you can drive without a fuel cap cause I accidentally left my fuel cap at teh gas station the other day, and drove back and it was still sitting on top the pump I was at. oops.

Seems to me you have one of two problems. The FPR is done for, or the fuel pump is done for. Just cause you hear the pump running doesnt mean its actually pumping anything. Does the car start right up when you turn the key? if it struggles and then starts, its probably the pump. If it starts right up but acts funny after, its probably the FPR. I can't think of anything else at the moment that would be the culprit.
 

·
Registered
Joined
·
430 Posts
I'd start with a new filter. Then check your gas cap...make sure it will hold and release pressure when it's supposed to. Then test the pressure out of ther FPR?
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top