ZCar Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
7,924 Posts
Discussion Starter #1
ok so that thump noise I keep getting from my front suspension since i replaced that ball joint...
I couldn't figure it out so i took my car back to that shop and they said that nothing looks wrong except that my sway bar looks worn out. I didn't know that a sway bar got worn out.. could this be true?
 

·
Registered
Joined
·
13 Posts
Sounds like strut mounts. Also check to make sure the caps that holds the strut cartridges in are tight. Worn ASB bushings and end like bushings can make noise but I'd check the others. Hope this helps
 

·
Registered
Joined
·
13 Posts
I saw your other post about your car wanting to wander. Check the strut mounts. If they are the originals they probably are the culprit to most of your noise and handing issues. I know you replaced a bad balljoint but if you can still feel it I bet this will help. KYB makes stock replacements.
 

·
Registered
Joined
·
7,924 Posts
Discussion Starter #4
Ok thanks TX, I was thinking about replacing springs/struts in a few weeks anyways, so looks like i'll just hope that replacing those parts fixes the problem.
 

·
Registered
Joined
·
2,953 Posts
whats a strut mount?
 

·
Registered
Joined
·
7,924 Posts
Discussion Starter #6
well theres a set up bushings and a bearing at the top of the front struts that mount it into the strut tower. If they get old (which they are) and worn i can see how it would cause the loose feeling i'm getting.
 

·
Registered
Joined
·
1,839 Posts
thumping and wandering? check the strut rod bushings, thats the rod that connects at the lower control arm and the frame crossmember at the front. the bushings are at the front.
 

·
Registered
Joined
·
548 Posts
It could be a combination of things. If the struts are shot. I agree, check the strut rod bushings and the strut tower mount. The sway bar could be clunking if the mount bushings are on their way out. I think I'd also check the steering rack mounts just to be safe. I had that happen on a 240Z. Since these parts are rubber they've probably seen better days.
 

·
Registered
Joined
·
7,924 Posts
Discussion Starter #9
"It could be a combination of things. If the struts are shot. I agree, check the strut rod bushings and the strut tower mount. The sway bar could be clunking if the mount bushings are on their way out. I think I'd also check the steering rack mounts just to be safe. I had that happen on a 240Z. Since these parts are rubber they've probably seen better days."

ball joints are good
sway bar looks good, but the rubber parts look worn
tension rods look good but rubber parts are worn
springs and struts are good, but the rubber is probably worn on them as well.
steering rack mounts are in good shape.

So I'm thinking that the strut bushings are probably the likely culprit. Would new ones come if i bought some new struts, or do i replace them separately? I'm going to be putting on suspension technics springs and some new struts in the near future. maybe this would be a good time to replace all the rubber with urethane bushings anyways...
 

·
Registered
Joined
·
548 Posts
The struts and new mounts are separate items. Look around E-bay and parts suppliers. If you're replacing those 2 items you should think about replacing the springs at the same time. That way you only need to take it apart once. Check the archives/posts here. Lots of good advice and laughs reading the posts. Good Luck.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top