ZCar Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Someone.. please help...

so this is my first post. I have a 76 280 I bought last year and I’ve been working on it a little. Doesn’t need much honestly the whole thing is completely stock runs and drives nice. The only thing is that the front brakes lock up, I never drive the car a far distance so it hasn’t completely locked up yet, but it’s gotten super tight before. At first the brakes feel normal, not stiff at all, the brakes will engage after pressing on the pedal maybe about an inch or two, it feels normal honestly. But after a few miles, the pedal begins to rise slowly and become stiffer. There’s pressure being built up SOMEWHERE but I can’t find it. I know it’s only the front brakes because after driving it for awhile the front wheels get HOT and the smell of the brake pads is there. the rear wheels are just normal.

Naturally, since the car Probably has a lot of original parts, I went straight to the front calipers, master cylinder And brake hoses And replaced them. It didn’t fix the problem. So honestly, what’s left is my brake booster, the proportioning valve, and the lines. I’ve been reading adjustments on the pedal that maybe the pedal is adjusted incorrectly not allowing the pressure to relieve. I don’t think it’s the brake booster, I changed the check valve and there was a decent vacuum when I pulled it from the brake booster.

what are your thoughts?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Thank you guys for your wisdom lol all of you have pretty good things to check out. I really want to eliminate the brake booster from troubleshooting so I’m gonna try chaseincats thing first. Let’s see how that goes. I’ll definitely check out the master cylinder and NP valve also. I’ll keep you guys in touch
 
1 - 2 of 2 Posts
Top