ZCar Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter #1
Ok, I am in the middle of a coolant system flush. I found the radiator plug, but for the life of me, I cant find the one on the passenger side of the engine!!! I looked at the only pic on the Haynes manual, but I cant seem to find it on the car. Do I have to jack up the car to get at it? Another quickie: Are there one or two drain cocks? I searched, and there seems to be a mention of one on the driver side of the engine as well. I know I can remove the lower radiator hose and thermostat and let it come out that way, but I dont want a coolant bath. BTW, I have a Turbo model.

Thanks
 

·
Registered
Joined
·
3,080 Posts
there are two, one on both sides of the engine. You need to look harder. Jack the car up, remove the splash guard, and then look for something that looks kind of like an outdoor hose hookup. I believe it's a 14mm bolt. I can take pics if you need a better description.
 

·
Registered
Joined
·
253 Posts
Discussion Starter #3
Pics will be extremely helpful!! I really appreciate it. The pic in the haynes is a real close up, so it isnt easy to see where it is on the engine (seems like it is a bit in front of the engine mount). I read the whole process, but it never mentioned raising up the front.

Again, thank you very much!
 

·
Registered
Joined
·
3,080 Posts
yep..you're going to need to jack it up.

I havne't looked at these in a while, but they are about in the middle of the block, and shouldn't be that hard to find.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top