ZCar Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
This is my first post so excuse me if it's longwinded! I have an 84' turbo w/ 119,000 miles that I recently got for $700. so far I had to replace some broken exaust studs, which meant removing the cylinder head. What fun! Just the other day I removed the auxiliary air valve along with the F.I.C.D. and cleaned them both. I re-installed them, checked the ignition timing, then adjusted the idle. Everything seemed fine until I accelerated down the street yesterday and when I got to about 3000...3500....or so rpm's (my tach doesnt work so I'm kinda' guessing) the engine kind of....shut off, like it was from a governer. I lifted the throttle and re-applied it and it ran fine. It only happens when it's climbing up in rpm's and under load. It doesn't happen reving the engine in the driveway only when it's under load, like when merging onto the freeway and having to get on it more than normal, if that sounds right! Anyway, I know my way around an engine and have no problem troubleshooting the 440 big block in my 51' dodge pickup but I'm just learning about this 300zx and hope someone can point me in the right direction . This is my 3rd z as I have had a 85' n/a and a 82' n/a 2+2, but this is the first one I need help with.

Thanks in advance for help!
 

·
Registered
Joined
·
1,644 Posts
Disconnect the TPS at the idle switch connector and see if the problem remains.



Post Edited (Sep 27, 9:18pm)
 

·
Registered
Joined
·
782 Posts
Let me guess its an automatic.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
Yes, It's an automatic and before I cleaned the a.a.v. and f.i.c.d. I didn't have this problem.

On another note, this is the first turbo car I have owned or driven for that matter and I can't believe how quick this car is!
 

·
Registered
Joined
·
793 Posts
Red you think its the FPR??
 

·
Registered
Joined
·
39 Posts
Discussion Starter #8
I replaced the fuel pressure regulator about a month ago so I'll test the fuel pressure next.


84 300zx turbo
k&n filter
msd ignition
 

·
Registered
Joined
·
39 Posts
Discussion Starter #11
I appreciate your suggestions but I haven't had time to run any tests yet as I have been working A LOT lately. I hope to have time to work on it sunday so I'll let you know how it went.
Thanks again
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top