ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
i'm having a little problem with my Z drifting from side to side when i'm drive over about 50mph. i'll be driving straight and the car will start to drift to the right, i correct this and about 2 seconds later it will drift to the left. i say drifting but its more like floating.
i haven't been under the car yet but i'm thinking that the sway bar bushings may have rotted out.
just wondering if anyone had any other ideas about what it might be before i have a look this weekend.

thanx for any help
Yam
 

·
Registered
Joined
·
78 Posts
sounds more like your steering rack bushings. i had the same problem on my 71 and 76. they are pretty simple to replace, and i would recommend urethane replacements. your sway bar bushings may be shot also, but they would not cause anything like you describe.
good luck
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
Unless it's real radical I think they call it bump steer. I read in the JTR manual the front end of the Z gets 170 lbs lighter at 70 mph (not sure of figures). Due to poor design of the front suspension, as the body lifts it changes the geometry and pulls the front of the tires inward (toe in). Mine drifted all over the place on windy days. If everything checks out and that is your problem there's a cure in the manual, something about redrilling the inner bolt holes on your control arm 3/4 of an inch higher. Stiffer springs are supposed to help also
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top