ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
625 Posts
Discussion Starter · #1 ·
Hey, I think I posted here once that it was alright to run without your vacuum advance. WELL DON'T!!! I have been running without mine for years based on some bad advice I read in a performance book one time. My car has idled like crap for years, but I thought it was due to my performance camshaft. Turns out that it was the lack of ignition advance that normally is provided by the vacuum advance at idle. I never could run enough static advance to make it idle right without it causing ping under acceleration when I didn't run the vacuum advance. It dumbfounds me now that I never tried to hook it back up, but sometimes logic escapes me!! If auto engineers put something on a car, chances are that nine out of ten times there is a good reason!!! BEWARE the stuff you read in performance books it is not always good advice!! Later,norm
 

·
Registered
Joined
·
996 Posts
Hey Norm!

What going on, Congrats on those track times from the other day. If you run no vacumn advance the distributor has to be modified internally to be advanced or it won't run right. I had mine done so I am not sure of what happened but my car idles smooth and doesn't ping at 8500 rpm. I guess it was done right, who knows! Take care
Matt
 

·
Registered
Joined
·
625 Posts
Discussion Starter · #3 ·
RE: Hey Norm!

Yeah, I think they advance the mechanicaladvance so that you have earlier initial ignition timing on the modified distributors. I guess you could use lighter springs or maybe weld up some portion of the hole so that the mechanical advance only advances 5 dgrees instead of 10-15 degrees. Later ,norm
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top