ZCar Forum banner

Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
304 Posts
Discussion Starter #1
backgrounded info: bought the car about 2 months ago everything worked as it should. last wensday i replaced an altenator that was overcharge due to a messed up voltage regulator. i put it on wensday and on the way home from school thursday it died. so i replaced it thursday night at 8 oclock in the dark and put in a new battery along with a new belt. once again everything worked as it should. today i was driving home from the gym and what happens you ask? the whole dash lights up and i see the voltemeter go from just under 15volts to 12. "F***!!!! There goes another one"

in talking with my dad and a few others i have come the conclusion that i have no conclusion to come to other than bad wiring. i am starting to get tired of going to autozone to get new altenators. i know most of them by name now and am cosidered family by a select few, its almost scary how often i am there. i just want my car to run right like it used too.

any help is much appreciated.

thanks in advance
zelotic
 

·
Registered
Joined
·
321 Posts
There is one other possibility. The alternators were bad to begin with. I have heard of many people that got bad alternators from Autozone among others. The best one was an individual had them test the alternators before leaving and they found 2 or 3 bad on the shelf before finding a good one.
 

·
Registered
Joined
·
304 Posts
Discussion Starter #3
man. good thing for that guy. only problem is, is that i had mine tested before i left the store the last time. everything checked out on it and it ran great for about 5 days, then it died
 

·
Registered
Joined
·
1,839 Posts
have the old alternator tested to find what made it die, if the first one failed due to a bad regulator and this one failed from another cause then the failures are unrelated. check both battery connections at BOTH ends, check to be sure the batt. wire at the alternator is hot with the key on. if its not the alternator wont work. if all thats ok then your problem is probably autozone,
 

·
Registered
Joined
·
304 Posts
Discussion Starter #6
the only reason that i dont think it was lemon altenators is that both of them worked for a period of time. the first one lasted 1 day and second one last for about 5 days.
 

·
Registered
Joined
·
304 Posts
Discussion Starter #11
life time warrenty
 

·
Registered
Joined
·
304 Posts
Discussion Starter #12
i found the problem to be to much air space between the mechanic and the wrench :( as i was puttin in the 2nd altenator i didnt tighten down the ground wire and the battery wire enough on the back of it so it wrattled loose. hey, its fixed, now i just need to fix the air space problem
 

·
Registered
Joined
·
880 Posts
i have bought 3 alternators from autozone that didnt last a week.. went to a respectable alternator shop.. and im still charging~
 

·
Registered
Joined
·
880 Posts
yeah i know.. i was just ranting about autozones alternators.. lol
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top