ZCar Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
this problem has me stumped. While I'm driving down the road the car will just die, everything else is working, lights, radio, heater. You can hear the engine and watch the tach. go down. I've tried pumping the gas pedal while it is dying but nothing will stop it. It won't start up again while it is quietly coasting, but as soon as I stop and put it in park or neutral it will start back up. There was one time where it caught it self and fired back up but that was only once. Please help.
 

·
Registered
Joined
·
61 Posts
Did you do anything to the car just recently?
I rebuilt my head a little while agao and that sounds what happend to me.
I was a combo of a fuel pump going bad and the timing(seems like it floods itself for a sec then fires right back up)
hope this helps
 

·
Registered
Joined
·
4,289 Posts
Hook a fuel pressure gauge up between the fuel filter and the top fuel rail.

Hook a timing light to the ignition system.

Go for a drive and when the engine stops which diagnostic tool also stops?

Wayne Monteath
Masham, Quebec.
 

·
Registered
Joined
·
3,310 Posts
If the engine and tach are going down together, it is most likely the fuel pressure dropping off. Go with Waynes suggestions on troubleshooting. You can connect the fuel pressure gage in and tape it to the windscreen on the outside and will be able to see if the pressure starts dropping at the same time. I would be looking in the direction of one of the fuel pump relays. Perhaps the recycling of the key from on to off after you stop is allowing they relay to reset dirty contacts and allowing the pump to work, or it could be crud in the fuel tank/fuel filter that is building up while driving then drops off when you get stopped, but you should do the troubleshooting first while driving it.
 

·
Registered
Joined
·
112 Posts
I own a 75 280Z that drove me crazy for a full year doing something very similar. In the end it was a non-eom fuel pump that had been installed after the factory original pump went bad. The headache was, an intermitent (now I work-now I don't) bad pump that took a year to finally die. I replaced it and havn't had the problem since.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
No, I haven't rebuilt the engine at all. This problem started about 3 months ago. The first time it died it ended up being one of the relays by the frame on the right side of the car had broken. Now it may go for 2 days and not die and then bam it may die 3 times in one run. The last time it died I ended up having it towed home because it wouldn't start but on that occasion it was the wire on the starter motor had came off. That wasn't why it died though. Once the starter wire was hooked up again it restarted. I have had this car for 5 years and have always had a problem and now just want it to quit being a pos. Thanks, Conniedeus79 wrote:
>
> Did you do anything to the car just recently?
> I rebuilt my head a little while agao and that sounds what
> happend to me.
> I was a combo of a fuel pump going bad and the timing(seems
> like it floods itself for a sec then fires right back up)
> hope this helps
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top