ZCar Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
358 Posts
Discussion Starter #1
I have an 83 280 ZX Turbo and I can not get over 3000 RPMs. If anyone has any suggestions PLEASE help
Anthony
 

·
Registered
Joined
·
1,056 Posts
> Your Throttle Valve Switch is faulty or has
> water in it. This is the problem that I had.
I just bought a 78 280Z and want to steam clean the engine. I did this years ago on a
77 Z I had but got water in my throttle valve switch. A mechanic blew it out and that
solved the problem. Unfortunately, I don't remember where the trottle valve switch
is. Could you please let me know where it is and what it looks like before I clean
my engine.
 

·
Registered
Joined
·
529 Posts
> I just bought a 78 280Z and want to steam
> clean the engine. I did this years ago on a
> 77 Z I had but got water in my throttle
> valve switch. A mechanic blew it out and
> that
> solved the problem. Unfortunately, I don't
> remember where the trottle valve switch
> is. Could you please let me know where it is
> and what it looks like before I clean
> my engine.

the TPS is located on the opposite side of the throttle likage on the throttle body. It is rectangular and has a 2 or 3 wire connector depending on year......
 

·
Registered
Joined
·
107,695 Posts
> the TPS is located on the opposite side of
> the throttle likage on the throttle body. It
> is rectangular and has a 2 or 3 wire
> connector depending on year......

The connector on my TPS has two wires going into it but a spot where it looks like a third wire should be. Is that how the two wire connectors should look? I have an 83 280zxt.
 

·
Registered
Joined
·
107,695 Posts
I had this same problem on a 83 280zxt. Try pinching the fuel return line. This raises the fuel pressure and will clear up the problem if it is fuel pressure related. Mine turned out to be a faulty fuel pump.

Eric

> The connector on my TPS has two wires going
> into it but a spot where it looks like a
> third wire should be. Is that how the two
> wire connectors should look? I have an 83
> 280zxt.
 

·
Registered
Joined
·
529 Posts
Re: TPS wires

Yes, the turbo models have the 2-wire tps. There is a spot for a third, but not used on the turbo.

> The connector on my TPS has two wires going
> into it but a spot where it looks like a
> third wire should be. Is that how the two
> wire connectors should look? I have an 83
> 280zxt.
 

·
Registered
Joined
·
107,695 Posts
Re: TPS wires

> Yes, the turbo models have the 2-wire tps.
> There is a spot for a third, but not used on
> the turbo.

Thanks! One less thing to worry about.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top