ZCar Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter #1
Ok, so my battery isn't holding a charge. It usually dies in about a day or two. Right now I have the negative battery terminal disconnected so it won't drain. I've taken it to 2 mechanics and both said they think it's a electrical problem. I forgot to ask if they checked the alternator and the belt and the electrolyte and some other stuff. Anyways, they said I should take it to a nissan dealership, someone that knows the electrical system of the car. Only thing is, I don't wanna have to pay the price for taking it to the dealership.

So anyways, could you guys help me out? Tell me what you think it is and how to fix it?

Thanks.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #2
Also, when I connect the battery, this thing starts making a clicking noise. I'll show you what it is because I don't know what it it. I think the mechanic said when he disconnected it, the battery drained slower. Not sure though.





Look for the white circle.
 

·
Registered
Joined
·
34 Posts
That's your idle speed controller. It recieves a constant 12+ supply and the negative side is controlled by the ecu. Something in the controller, your ecu, or your wiring is possibly causing a short and draining your battery. Will the battery die if you let it sit only or will it do it when you drive too?
 

·
Registered
Joined
·
255 Posts
Discussion Starter #4
Well I've driven it for abour 30 mins and the battery didn't drain at all. Volts didn't go down or anything. If I let it sit there for a day or 2, the battery drains dead then I have to buy a new battery. That's why I disconnected the neg. terminal.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #6
Okay. So is there anyway to diagnose this problem and fix it? or should I just take it to a nissan dealership since I'm not good with electrical sh!t.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #8
Could the fact that some of the idiot lights don't come on my dash.. Cuz I see in this pic



The lights come on in that pic.. The only light that comes on in my Z is the seatbelt light. Even when I turn something on like my lights, it doesn't say "Lights" on the dash.

So, could that be part of the problem or a whole different problem?

Edit - When I open my door, the door ajar light doesn't appear.



Post Edited (Jun 19, 4:38pm)
 

·
Registered
Joined
·
1,644 Posts
May or may not be related.
Have the problems existed since you bought the car or did it happen out of the blue? Or has someone screwed around with it?
BTW, if the battery drains you do not necessarily have to buy an new one.
 

·
Registered
Joined
·
23 Posts
To check if the alternator is dead, while the car is running, pull the negative cable off. If the car goes dead, then it's the alternator. If it doesn't, then something else is wrong.

TheMetalGod
 

·
Registered
Joined
·
3,080 Posts
um...no that doesn't work.

I'll put money on your hood switch or your hatch switch are broken and your Z thinks they are always open.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top