ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter · #1 ·
I have been trying to get my car running for thepast 2 months with no progress. My dad had try to work on my car by putting on a fuel pump from a grand national which when I returned home from vacation had fried something. My dad said he smelt something electrical burning after he started it then it just stoped. I have replaced relays (Thanks you guys) and tried to follow the wires to see if they fried themselves but nothing. I can get the engine to turn over but the fuel pump will not come on. I have done all I can but replace the CPU. Could this be my problem? any advice is GREATLY appreciated. Tony
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #2 ·
Fuel pump relay switch...

Check under the drivers side dash. Right above the puter is a relay for the fuel pump. If this goes bad the pump will not come on. Try bypassing this with a hot wire and switch to the fuel pump. If the pump comes on and the car runs it is the relay. On my car the problem was never tracked down so I still have the toggle switch in place. Good luck...
Tony

> I have been trying to get my car running for
> thepast 2 months with no progress. My dad
> had try to work on my car by putting on a
> fuel pump from a grand national which when I
> returned home from vacation had fried
> something. My dad said he smelt something
> electrical burning after he started it then
> it just stoped. I have replaced relays
> (Thanks you guys) and tried to follow the
> wires to see if they fried themselves but
> nothing. I can get the engine to turn over
> but the fuel pump will not come on. I have
> done all I can but replace the CPU. Could
> this be my problem? any advice is GREATLY
> appreciated. Tony
 

·
Registered
Joined
·
46 Posts
> I have been trying to get my car running for
> thepast 2 months with no progress. My dad
> had try to work on my car by putting on a
> fuel pump from a grand national which when I
> returned home from vacation had fried
> something. My dad said he smelt something
> electrical burning after he started it then
> it just stoped. I have replaced relays
> (Thanks you guys) and tried to follow the
> wires to see if they fried themselves but
> nothing. I can get the engine to turn over
> but the fuel pump will not come on. I have
> done all I can but replace the CPU. Could
> this be my problem? any advice is GREATLY
> appreciated. Tony

What year is your car? If it is a 75-76 280, then i might know what your problem is. the switch to turn on the fuel pump in these cars is in the AFM, beleive it or not. I had that problem. I dont know if you can get it fixed, or if you have to get a new one. I got a new one.
 

·
Registered
Joined
·
46 Posts
> I have been trying to get my car running for
> thepast 2 months with no progress. My dad
> had try to work on my car by putting on a
> fuel pump from a grand national which when I
> returned home from vacation had fried
> something. My dad said he smelt something
> electrical burning after he started it then
> it just stoped. I have replaced relays
> (Thanks you guys) and tried to follow the
> wires to see if they fried themselves but
> nothing. I can get the engine to turn over
> but the fuel pump will not come on. I have
> done all I can but replace the CPU. Could
> this be my problem? any advice is GREATLY
> appreciated. Tony

What year is your car? If it is a 75-76 280, then i might know what your problem is. the switch to turn on the fuel pump in these cars is in the AFM, beleive it or not. I had that problem. I dont know if you can get it fixed, or if you have to get a new one. I got a new one.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top