ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
I have had a problem with my 81 na.for the past few weeks. I have had this posted before and tried the things that where said to try. It does not want to rev past 4,000. Buy this I mean it is like you start putting a heavy load on it(neutral). It still revs some-what smooth. I though that if was the igintion timing, but is set right by the book. So I though it might be the valve timing but have try lots of defferent settings. It seems that I have not bent any valves is the testing.
As of now it does not want to rev past 2.5 rpm. So the valve timing is now wrong(I guess). The car runs like crap with the V. timing set to the proper setting. Couldthis be because of another problem that is some what fixed by having the V.timing set wrong.

I surly hope one of you guy/girls can help me fix this problem soon.

THANKS!!
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
RE: Please Help Me!!!Don't just let me fly by!!

The valve timing is one of the last things I would check, and it would not be the reason for your problem. Rev limitting is almost always a fuel problem, mainly a lack of fuel. A clogged fuel filter or worn out MAF meter are the first things I would check. Also, make sure that the ignition timing advances as you rev the engine, probably to at least 10 degress above static timing (for a total of 17 degrees or so BTDC) by no later than 1500 rpms. I suppose an extremely clogged air filter or catalytic converter could also cause your problem, but I have never encounterd this before.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top