ZCar Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
Hey,
Would anybody have suggestions on things to check for after complete rebuild of L28 N42 Fuel Injected Zcar? I just got through rebuilding and it won't start. I made sure that it was timed correctly. It is getting fire and with a timing light hooked up while cranking, it hits in the correct place everytime. It seems to be getting gas, but don't know for sure if it has pressure at the injectors. Is there something I need to do to get pressure in the gas lines after having them disconected for a while? My book has nothing about priming the lines after a rebuild. I did notice that the cold start valve doesn't seem to be functioning correctly...If my assumption about it is correct it should inject fuel into the intake manifold when the car is started cold. It did not release any fuel when removed from manifold.
Any help will be appreciated!!!!!
If you have any suggestions or solutions or need more info...I will be very happy! Course I would have been more happy if the thing had just fired up :(

StephenRay
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
RE: Help!!! Z won't start!

The way I primed my fuel system is to remove the cold start valve, place in a container and cover opening with a rag. Disconnect the wire from the starter soleniod..so the engine does not crank. Use and old injector connector with leads on it to hook up to the cold start valve and have other wire lead long enough to reach your battery....thats to keep all sparks a long way from the cold sart valve. Have a helper in the car turn the ignition key to start. This turns on the fuel pump. Then trigger the cold sart valve with the 12 volt leads until the air is purged from your system. Be very careful as fuel vapors and sparks are an explosive combination! This procedure is in the manuals for de-pressureizing the fuel system and checking operation of the cold start valve. Hope this helps...Good Luck!

StephenRay wrote:
-------------------------------
Hey,
Would anybody have suggestions on things to check for after complete rebuild of L28 N42 Fuel Injected Zcar? I just got through rebuilding and it won't start. I made sure that it was timed correctly. It is getting fire and with a timing light hooked up while cranking, it hits in the correct place everytime. It seems to be getting gas, but don't know for sure if it has pressure at the injectors. Is there something I need to do to get pressure in the gas lines after having them disconected for a while? My book has nothing about priming the lines after a rebuild. I did notice that the cold start valve doesn't seem to be functioning correctly...If my assumption about it is correct it should inject fuel into the intake manifold when the car is started cold. It did not release any fuel when removed from manifold.
Any help will be appreciated!!!!!
If you have any suggestions or solutions or need more info...I will be very happy! Course I would have been more happy if the thing had just fired up :(

StephenRay
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top