ZCar Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
650 Posts
Discussion Starter · #1 ·
well i just replaced my alternator on my 71 (L28) and its just not pumping out enough amps for all the electronical extras ive added.

in JC Whitney i've found a duel battery setup kit for around $46. what i wanted to to do was run the regular electrical system on my Optima yellow top, and run all the other things like the sound system, alarm, etc. off the secondary battery.

however, when i asked around, i was told that this is fine except that there would be more strain on the alternator (70 amp i think but could be as much as 90 amp). they told me to get an alternator with around 120-140 amps. and if i did this i probably wouldn't even need the second battery.

so the question is, does anyone know where to get an affordable alternator that puts out 120-40 amps??? and guys, $170 - 190 is not exactly affordable on my limited budget. =)

oh and an easy installation would be great. Summit carries those one wire hookup alternators, but Summit also focuses on domestic motors. so if anyone has any leads it would be greatly appreciated.
 

·
Registered
Joined
·
107,695 Posts
> well i just replaced my alternator on my 71
> (L28) and its just not pumping out enough
> amps for all the electronical extras ive
> added.

> in JC Whitney i've found a duel battery
> setup kit for around $46. what i wanted to
> to do was run the regular electrical system
> on my Optima yellow top, and run all the
> other things like the sound system, alarm,
> etc. off the secondary battery.

> however, when i asked around, i was told
> that this is fine except that there would be
> more strain on the alternator (70 amp i
> think but could be as much as 90 amp). they
> told me to get an alternator with around
> 120-140 amps. and if i did this i probably
> wouldn't even need the second battery.

> so the question is, does anyone know where
> to get an affordable alternator that puts
> out 120-40 amps??? and guys, $170 - 190 is
> not exactly affordable on my limited budget.
> =)

> oh and an easy installation would be great.
> Summit carries those one wire hookup
> alternators, but Summit also focuses on
> domestic motors. so if anyone has any leads
> it would be greatly appreciated.

You would be lucky to find an
aftermarket alternator(Lestek, Phoenix
Gold, Stinger, etc...) for less than
$400.00. And that does not include the
cost for the custom bracket you would need to install it. You could try taking yours to an alternator shop to
be rewound and that would maybe get
you 20-30 more amps. You have to watch
how many amps you pass through the
factory nissan harness because you
might burn it(at least that what all
the local stereo shops tell me).
 

·
Registered
Joined
·
107,695 Posts
Getan83ZxAlt75amps

anything more charge pulling than that, and you'll start frying wires, fusible links, etc. WHat THE **** DO YOU HAVE IN THAT THING, LOL a **** Radar station?
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #4 ·
Re: Getan83ZxAlt75amps

> anything more charge pulling than that, and
> you'll start frying wires, fusible links,
> etc. WHat THE **** DO YOU HAVE IN THAT
> THING, LOL a **** Radar station?

haha no but close. right now im running 2 100watt amps with a crossover and of course the head unit. also switched over to electric fuel pump and fan. im going to be adding a turbo timer and boost controller as well. oh, and dont forget the fog lights and alarm.

the reason i brought this all up is that, when i have the stereo system on and i need to signal, the signals steal power from the bass amp. and when i have the lights on it takes the signals a long long long time to turn on if they turn on at all.

ive checked the wiring for breaks, bad grounds, bad connections. ive also changed the flasher relay and alternator and upgraded to an optima yellow top, deep cycle battery. but still the same problem. the only thing i havent changed is the voltage regulator.

anyone have any ideas, the only two things i can think of are a stronger alternator or a duel battery hookup. help!!!
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #6 ·
Re: Do the hazards work?>

yup! hazards work fine. even with the lights on and system going.
 

·
Registered
Joined
·
972 Posts
Re: Getan83ZxAlt75amps

Sounds more like a grounding problem in the dash. Are you using any of the factory stereo wiring? That would cause problems since it wouldn't be able to handle the power of a modern stereo... even just the head unit. Also be sure to run seperate grounds for all your add-on stuff. Check your voltages at the fuse panel for why your blinkers aren't working.

> haha no but close. right now im running 2
> 100watt amps with a crossover and of course
> the head unit. also switched over to
> electric fuel pump and fan. im going to be
> adding a turbo timer and boost controller as
> well. oh, and dont forget the fog lights and
> alarm.

> the reason i brought this all up is that,
> when i have the stereo system on and i need
> to signal, the signals steal power from the
> bass amp. and when i have the lights on it
> takes the signals a long long long time to
> turn on if they turn on at all.

> ive checked the wiring for breaks, bad
> grounds, bad connections. ive also changed
> the flasher relay and alternator and
> upgraded to an optima yellow top, deep cycle
> battery. but still the same problem. the
> only thing i havent changed is the voltage
> regulator.

> anyone have any ideas, the only two things i
> can think of are a stronger alternator or a
> duel battery hookup. help!!!
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top