ZCar Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Ok so by now i realized that my ZX is a piece. But i love this car, so im keeping it. Well anyways my battery only charges intermittently (sp?), and i was thinking i either had a bad voltage regulator (it had been over-charging a little bit) or a bad alternator. But, then i had all my insturments and lights go out while i was driving. The engine kept running perfectly while the dash lights and radio went out. Also, not just the digital speedo and tach went out, the digital climate control and radio went out too. 5 or 6 seconds later everything came back on. This has happened 3 times. Could this be the alternator? It seems like something more. Anyways im geting tired of needing to be jumped and plugging my car in at night. Any suggestions?
 

·
Registered
Joined
·
1,839 Posts
if the alternator charges intertmittent and sometimes overcharges its a bad voltage regulator. which you probably realize is built into the alternator, i'd replace the alternator.
 

·
Registered
Joined
·
2,227 Posts
Take the alternator out and run it down to your local autoparts shop and have them test it. The alternator is not a hard part to remove and after you've done it a few times you can pull it out without having to get underneath the car (but either way it's easy).

This way you won't have to worry and wonder - you will know if it is or it isn't.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top