ZCar Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
When i first get in my car, home or school, it seems as if the engine is not warmed up, the engine hesitates bad. It takes off really slow, foot to floor, and then it flys. It scares me cuz i almost got creamed one day. Someone last night suggested i set the timing. Me and dad did it. The timing was way off, like somewhere around 20. But it still hasn't solved the prblem.
Another thing, once i'm going down the road, i feel like the pedal should be farther, there is nothign stopping it. When we push on that arm on top of the motor, the engine revvs up way higher, and doesn't seem to hesitate either. We can't figure it out.
Are these cars prettty responsive. Neither of us has ever driven on.

Ihave a 1982 280zx GL 2+2 non-turbo w/ T-Tops
**keep in mind, this is my FIRST car and i bought it for 800, but it has 273,000 miles, but that engine runs as smooth as a sewing machine.

all help is apppreciated

simon
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
When you are in neutral and press the accelerator pedal all the way down, does it exhibit the same sluggish behavior, or does it rev up to redline with ease? Is it an automatic?

These cars are very responsive and peppy. You may have a clogged catalytic converter. This is common problem. If so, best bet is to replace exhaust from manifold back with at least 2.25" exhaust.

You may want to re-post your Q's again to put them back at the top of the forum.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top