ZCar Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
this is a NA 280zx 83. whenever i start my car its real unstable. i cant rev it pass 2.5k, even when im in gear rolling. i do notice white smoke coming out the exhaust though. to try and solve the problem i replaced cap and rotor, spark plugs, wires, and did a compression check. everything went good, but i still have the problem. any idea?

quick question, is there a hose kit i can buy to replace all the air and/or fuel lines in the engine bay? there are kinda stiff thats where i might be losing some pressure. thx again laters
 

·
Registered
Joined
·
44 Posts
Does it idle OK but stutter badly when accelerating?
Fuel pump, plugged filter, or crushed fuel line, most likely.
Same thing with my '83 3 weeks ago. New plugs, plug wires, cap, rotor, swapped the entire fuel rail from my '82, problem remained.
$250 for new pump from Victoria British ("generic" replacement pump; MSA out-of-stock of Nissan new and rebuilt, dealer wanted $300 for Nissan pump w/2-week wait).
To be sure you'll need to check fuel pressure at the fuel rail.
Good luck.
Doug
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
forgot to put in a bit of info. after five minute of not reving past 2500 it will run normal. it like it need a real warm up before driving.

the next thing im going to replace is fuel pump, because i think its past its lifetime. when the cars on you can hear it hummm real loud so.
 

·
Registered
Joined
·
75 Posts
White smoke? Sounds like head gasket. Or somthing is cracked. Check compresion, if thats ok take it to a radiator guy. Let them pump up the cooling system. Yhey can tell if you have a bad seal with the head. Sorry but with the white smoke it looks like somthing with the head.
JOE
 

·
Registered
Joined
·
1,985 Posts
I have an 83 turbo, I have the same problems you describe. It backfires through the intake when cold, but runs fine once warmed up. The white smoke just started the other day. When cold it blows tons of it (white smoke is coolant right). But once warmed up the white smoke disappears. I'm wondering if some sort of vacuum probelm would let coolant into the intake. I am praying it's not the head gasket.

Let me know if the new fuel pump solves the crappy power when cold problem.

Josh
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
sucks not knowing what it was. compression came out ok, but the last cylinder was pretty low, but within the standard. i dunno when ill get the fuel pump my wallet says no. sucks. yeah im wondering if it is a vacum problem, the other night i found a crackin vacum line not even connected. it helped a little, just lowered the idle a bit, but didnt solve the problem. im going to look for more rubber lines in the engine bay that are cracked. i will probaly change head gasket. a friend of mine works at winchester auto. that place is the best, smart workers and carry alot more then kragen and pep boys and most auto stores ive been to. the come highly recommended! ill post how the install goes with the head gasket. maybe a week or two.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #8
i might of found the problem. i got this throttle body cleaner that my friend uses. and just wanted to clean mine out. i took out the mass air flow sensor, or whatever the silver box is before the throttle body and cleaned everything out. when i was putting everything back, i noticed that the rubber arm going from the MAS to the throttle body did not fit all the way over the flange of the MAS. to make sure that this was correct i took the whole thing out and looked at the wear/oxidiation. where the boot covered it was a shiny silver. the shiny part is no where on the bottom though. so the boot was only fitting over on the top side. thats why i found it had to re-install the MAS so im thinking that air is leaking out. im out going to pick up another intake boot/arm(whatever you prefer to call it) sometime in the near future. makes sense?
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top