ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

· Registered
Joined
·
107,597 Posts
> Being from the southern part of Cinci we
> have had a bad spell of weather lately. My
> girlfreind drove her car with a frozen
> radiator. I repaired the hose, replaced the
> thermostat with the expectation that I fixed
> the car. She told me after blowing the hose
> she continued the drive until she got to the
> next offramp (2-3 miles) it starts and Idles
> fine but when you try to accel, after 2
> seconds the car hesitates then goes back to
> accel. This repeates until I get tired and
> want to bomb the car. I'm wondering if my
> air-flow meter is stuck or if I have a
> bigger problem. Find me a solution
> please!!!!

> Joe

Check your throttle position sensor connector. Probably got water in/on it when hose blew. It can fill up with water since the connector points up. Dry it out, Hopefully will fix the problem. This happened to my 83ZXT after I washed the engine. Good luck!
 

· Registered
Joined
·
107,597 Posts
>JOE

I HAVE A 82 ZX THAT HAS HAD THE SAME PROBLEM AND THERE WAS WATER OR CORROSION IN THE CONNECTOR OF THE THROTTLE POSTIONING SWITCH , JUST DRY OR CLEAN THE CONNECTOR AND APPLY SOME DIELECTIC TUNE-UP GREASE TO THE CONNECTOR AND REPLUG IT,THAT SHOULD FIX YOUR PROBLEM.
YOU CAN FIND DIELECTRIC GREASE AT ANY AUTO PARTS LIKE PEPBOYS, OR AUTOZONE.
IF YOU NEED ANY MORE HELP FEEL FREE TO DROP ME A LINE.

MD MIZE
 

· Registered
Joined
·
107,597 Posts
> I HAVE A 82 ZX THAT HAS HAD THE SAME PROBLEM
> AND THERE WAS WATER OR CORROSION IN THE
> CONNECTOR OF THE THROTTLE POSTIONING SWITCH
> , JUST DRY OR CLEAN THE CONNECTOR AND APPLY
> SOME DIELECTIC TUNE-UP GREASE TO THE
> CONNECTOR AND REPLUG IT,THAT SHOULD FIX YOUR
> PROBLEM.
> YOU CAN FIND DIELECTRIC GREASE AT ANY AUTO
> PARTS LIKE PEPBOYS, OR AUTOZONE.
> IF YOU NEED ANY MORE HELP FEEL FREE TO DROP
> ME A LINE.

> MD MIZE
T P S
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top