ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
Please help, I have a 1982 280ZX with t-tops. The problem is that the plastic pieces that glue on to the glass to hold the covers keep popping off. I have tried a couple of different adhesives but with only limited success. Does anyone know of a paticular glue that will work. It is hot here in SC and the car interior gets too hot without the covers.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
Go to a windhsield shop, and have them glue those on using
the same glue that they use for rear view mirrors. Joe
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
<b>RE: 82 280ZX T-top Covers keep popping off</b>

I had the same problem last year - I was trying everything possible and they wouldn't stay. So I had some 5 minute automotive epoxy glue that was laying around and decided to try it. I first cleaned both areas with my wifes nail polish remover (glass and plastic piece) mixed the glue, mounted the piece, let it set for about 20min and haven't had a problem since.

Hope this helps - let me know if you try it.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #4 ·
The key is first cleaning thoroughly. You have to get all the old stuff of the glass and clean it with alcohol or something really good. Buff the glass with a soft cloth only making sure there is no residual. I got some epoxy from Wallie World; one that was pretty specific for glass and plastic. I set the pieces by installing them on the sunshields and applying glue. Put the shields in place and put a weighted object on the sun-shade. Left em for at least 12 hrs-probably 18. I haven't had them come loose after a year in Tenn. Car never gets that hot inside though being white with louvers.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top