ZCar Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 82 280zx and I am having problems with my interior lights. At first my map light and dome light quit working, but I still had the lights down by your legs and the light delay worked. Now all the dome lights quit except for the ones on the door that still come on when I open the doors. Also I no longer have door keyhole light or ignition key light. I have checked the main fuse, fusible links and light relay under the hood and they all seem to be fine. Also checked bulbs on lights and they were fine. I cannot find the light timer control and cannot find a bad ground anywhere evident. Any ideas or suggestions would be great. I hate using a flashlight!
Davo1482
 

·
Registered
Joined
·
2,416 Posts
"I cannot find the light timer control ' its under the passanger kick panel, and I mean under...its a real pain to get to, theres also a accessory relay under there, probably where you problem is coming from, but I find my lights on my 82 tend to not come on, due to loose, 23 years old you know.

I just beat the lamp and it shines again, for awhile.
Charles
 

·
Registered
Joined
·
744 Posts
I'd check all the fuses, and maybe pull the fuse block. I seem to remeber that when mine was doing that, replacing fuses worked. i think the dome and map lights were a different fuse that the doors, and it wasn't marked well or at all.
 

·
Registered
Joined
·
144 Posts
I just recently had a similar problem. After much searching, I pulled the fuse panel loose slightly and found that the fuse holder had been pushed thur and was hanging behjind. I pushed it back in place and ALL WAS CURED.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top