ZCar Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
I pulled the stock air filter system out of the Z and installed the K&N using the PVC. Didn't take long and all connections are tight. Only problem is that when I rev the motor it doesn't return to idle for a while. Motor just sits there holding the rpm's up for a while. Any advice???
 

·
Registered
Joined
·
1,610 Posts
BCDD Problem?

> I pulled the stock air filter system out of
> the Z and installed the K&N using the PVC.
> Didn't take long and all connections are
> tight. Only problem is that when I rev the
> motor it doesn't return to idle for a while.
> Motor just sits there holding the rpm's up
> for a while. Any advice???
Joe,
What has changed? Unless you accidently knocked something loose, like a vacuum hose, the onlu thing that would have changed is the total vacuum being pulled on the intake manifold due to reduced restriction. That may affect he BCDD?? Not sure. E-mail Steve Grabber and see if he has encountered anything like this. First I've heard of it so it's not a real common phenomena. You may have just been on the edge. Easiest way to tell would be to just put the old filter box and filter on and see if it goes back to normal. If it does, it's the installation. If it doesn't - oops! It is something else and you need to look around under the hood a bit for something that isn't the way it was.
Also, did you absolutely ensure all your fittings are air tight?
Phantom
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
Re: BCDD Problem?

Dealer said I had a bad AFM.. Running too lean, I installed various resistors inline with the water temp sensor(Not for temp gauge)and reduced to a 165 ohm resistor and problem is fine now..
 

·
Registered
Joined
·
1,056 Posts
Re: 78 K&N RU-0900=REASON FOR PRObLEM

> I pulled the stock air filter system out of
> the Z and installed the K&N using the PVC.
> Didn't take long and all connections are
> tight. Only problem is that when I rev the
> motor it doesn't return to idle for a while.
> Motor just sits there holding the rpm's up
> for a while. Any advice???

Grandpa:
I made the same change on my 77..had the same problem... my cure was that the AFM had to be readjusted. You are receiving more air now with the new K&N so your fuel/air mixture is off. Least wise that is how mine was corrected.

Hope it helps.

dave
 

·
Registered
Joined
·
1,056 Posts
Re: 78 K&N RU-0900=TO ANSWER (2)E-MAILS

> Grandpa:
> I made the same change on my 77..had the
> same problem... my cure was that the AFM had
> to be readjusted. You are receiving more air
> now with the new K&N so your fuel/air
> mixture is off. Least wise that is how mine
> was corrected.

> Hope it helps.

> dave

After installing the(Steve Grapers method) of the K&n filter system I engine was running strangely so I took the car to my Z Mechanic and he told me the reason for the problem was that with the new filter system the engine was receiving more air than the stock filter supplied. thereby giving the engine/fuel too much air.
He said he would have to adjust the AFM to compensate for the extra air coming into the AFM. As it was explained to me he removed the side cover and adjusted the needle to lower the amt of air thru the meter. The direction in which the needle is moved ( left or right) allows less or more air. He did not want to go into details other than that. From what others have told me very small increments are made each time. The way I see it is that a mechanic has the gauges to check the fuel/air mixture for proper adjustment.

AS far as difference in performance it seems to have a little better accellerations than it had. Future mods of headers and exhaust may even help that little extra ump in an older Z.. Im not looking into setting any records just a little better performance when I want.

Dave....
77 Zapped Z
ZCSD #19
 

·
Registered
Joined
·
235 Posts
PCV K&N vs MS Auto K&N

> After installing the(Steve Grapers method)
> of the K&n filter system I engine was
> running strangely so I took the car to my Z
> Mechanic and he told me the reason for the
> problem was that with the new filter system
> the engine was receiving more air than the
> stock filter supplied. thereby giving the
> engine/fuel too much air.
> He said he would have to adjust the AFM to
> compensate for the extra air coming into the
> AFM. As it was explained to me he removed
> the side cover and adjusted the needle to
> lower the amt of air thru the meter. The
> direction in which the needle is moved (
> left or right) allows less or more air. He
> did not want to go into details other than
> that. From what others have told me very
> small increments are made each time. The way
> I see it is that a mechanic has the gauges
> to check the fuel/air mixture for proper
> adjustment.

> AS far as difference in performance it seems
> to have a little better accellerations than
> it had. Future mods of headers and exhaust
> may even help that little extra ump in an
> older Z.. Im not looking into setting any
> records just a little better performance
> when I want.

> Dave....
> 77 Zapped Z
> ZCSD #19
Does the afm have to be adjusted with the MS Auto K&N system as it does with the home mechanic PVC method?
 

·
Registered
Joined
·
96 Posts
Re: AFM adjustment???

> Does the afm have to be adjusted with the MS
> Auto K&N system as it does with the home
> mechanic PVC method?

I think there's a question mark here, IMO. I don't understand why the AFM would keep the rpm from dropping back to normal. I've messed with my AFM, both the idle enrichment adjustment screw and the spring which puts the tension on the air flap. Idle speed may change a few hundred RPM, but it never affected it as described.

I have also taken my air filter completely out at times in the garage while tuning, etc. I would think this would allow even more air into the AFM than even our beloved K & N. My car never had this high idle problem with it out.

If I'm missing something here, please explain. I'd love to understand this better.

Matt
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top