ZCar Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
1,056 Posts
Discussion Starter · #1 ·
I have a 77 Z. Just got it back from the body shop after being there fro 3 months. I had remove the air filter before leaving it at the shop. The shop moved the car outside daily when not working on it. They also ran the gas tank dry TWICE. They put $2.00 of gas in it for my ride home. Got it home to the garage and started it only once. Today I backed the car out of the garage and parked it in the driveway for @ 1 hour while I swept the garage floor. The driveway is on a slight incline up to the garage and the car was facing it. I went to put car back and it wouldn't start. The gas gauge was on empty. I got 2.5gls of Super and car still doesn't start. Smells like engine is flooded. Does flooding, gas smell mean fuel is OK? I may not be getting a spark. I have new dist, wires, plugs and ing plugs.

Any info is greatly appreciated.
 

·
Registered
Joined
·
46 Posts
If after you try to crank it a few times, you smell gas, then chances are there is nothing wrong with your fuel system. (But not always). Check your coil. If there is no spark then thats the problem. I had a similar problem, but i had spark and gas, too much gas. Turns out i needed a new AFM and a CPU. Talk about some bucks. Hope this isnt you problem. What was it in the shop for? If it has anything to do with this problem, then you better get it back there.

Hope this will help you

Mike B.
 

·
Registered
Joined
·
1,056 Posts
Discussion Starter · #3 ·
It was in for body work, they were welding need the CPU (near the drivers kickplate), but moved the box and shieded it from the heat. If there was damage I shouldn't have been able to drive it home or move it. How much is new compluter module and what is the A..?
 

·
Registered
Joined
·
432 Posts
> It was in for body work, they were welding
> need the CPU (near the drivers kickplate),
> but moved the box and shieded it from the
> heat. If there was damage I shouldn't have
> been able to drive it home or move it. How
> much is new compluter module and what is the
> A..?

Dave, I don't think this is going to be all that bad. I used to run my '78 out of gas more often than i care to admit, and fuel injection is really hard to prime once this happens. Just try holding the gas pedal all the way down to the floor and crank the ignition. it might just start!! Can't guarantee how good it will run, though.
 

·
Registered
Joined
·
46 Posts
You wanted to know how much a computer is? A nissan one will run you about $450. I know motorsport sells them, but i dont know what the quality is like. You can probably get one from a junk yard too, just make sure there is some kind of warranty.

AFM=Air Flow Meter.

Im not saying this is what your problem is. Try everything else first. Try what Tim says. This would be a last resort, just because of the cost.

But what you said about it not working when you picked it up is not necessarily true.

Let me tell you what happened to my CPU. I noticed that every time I would shut either of my doors my car would cut off. (Kinda hard not to notice) I had no clue what it was. In desparation i started bumping everything i could think of lightly with my hand, and when i hit the cpu it cut off. I took it out of the car to see if i could find any broken connections and when i did i dropped it on the driveway. DOH. I opened it up and didnt see any broken connections and put it back in and it didnt do it anymore. A couple of weeks later it got to where it would cut off when it was hot and then it wouldnt start at all. To make a long story short i took it to nissan and got my car back $1200 poorer.

My cpu was bad but my car still ran, for a little while. Oh well.
Sorry to babble. Im probably blowing this way out of porportion. I hope so. Maybe this will help you out.

Good Luck.

Mike B.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top