ZCar Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Thanks for those that helped me solve my headlight troubles. How about helping with the turn signlas now. I know I read about this here before, but I can not find the info again. Turn signals work, but are slow and very dim.

Thanks
Scott
 

·
Registered
Joined
·
104 Posts
You can pull apart the switch all the way down to the little electrical box that controls what the handle does to the signal. I'd pull this thing apart and clean it real well and make sure the little spring and ball inside are in ok shape. I've done this on all the turn signal switches I've worked on (I lost count, and I've only had 2 z's), and it really helps the signal. Hope that helps. Lee Z
 

·
Registered
Joined
·
394 Posts
LOW260, was the headlight problem a disconnect at the Turn Signal DIMMER SWITCH?

As previously mentioned cleaning goes a long way. You may also want to verify you have the correct wattage bulbs installed and that they work - different resistance. Check your connections and after all else try another FLASHER UNIT.

RLS30
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
The headlight trouble did end up being the switch itself. I have a new on on order and feel good about it. I will try another flasher as the problem sems that the turn signal is not on long enough to let the lights shine.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
OK I did some more testing so I need some more help. I swapped flashers witht he hazards and have the same trouble. The hazards are good and bright no matter which flassher is used. I find that I have low power feeding the switch itself. So the question i have now is ... what is the flow of juice. Is it fuse box to flasher to switch to turn signals? if so it could be the fuse box or wiring between. Thanks and keep helping

Scott
 

·
Registered
Joined
·
394 Posts
Turn signals path goes like this: BATTERY, FUSIBLE LINK (black), shunt, FUSIBLE LINK (green), IGN. SWITCH, FUSE (10A), HAZARD SWITCH, FLASHER UNIT, TURN SIGNAL SWITCH and then BULB.

RLS30
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
Thanks Z-Quest RLS30 1/2. Since the hazards work well I am headed to check the connectins from the fuse box to the flasher and then to the switch. I tested with a test light and seem to be low on power headed to the switch. I will let you know the out come or be asking more help. Thanks
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Lee, Thanks for the input. After doing more testing I decided the switch was it. I figured might as well take it apart or buy a new one. Took it apart and it works great now. I just odered new headlight switch but after this turn signal issue, I took the head light switch apart and fixed it too. Thanks a million.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top