ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
107,597 Posts
Discussion Starter · #1 ·
I havnt had my 73 for that long. It is hard to start, I have replaced spark plugs, rotor,points, and cap. It has earlyer round top carbs. It has an electric fuel pump, no mechanical fuel pump and a regulator that I have tried setting from 1 1/2 psi to 5 1/2
psi. I usually turn on the ignition and let the fuel pump run for 1/2 to 1 min, then pump the gas peddle like **** for another min, then crank 4 - 5 times, while still pumping the gas and then it starts. It runs like a dream when warm, but please tell me their is an easyer way to start it !! Also I wondered if I should be using lead fuel additive ?
Thanks,
Adrian
 

·
Registered
Joined
·
107 Posts
> I havnt had my 73 for that long. It is hard
> to start, I have replaced spark plugs,
> rotor,points, and cap. It has earlyer round
> top carbs. It has an electric fuel pump, no
> mechanical fuel pump and a regulator that I
> have tried setting from 1 1/2 psi to 5 1/2
> psi. I usually turn on the ignition and let
> the fuel pump run for 1/2 to 1 min, then
> pump the gas peddle like **** for another
> min, then crank 4 - 5 times, while still
> pumping the gas and then it starts. It runs
> like a dream when warm, but please tell me
> their is an easyer way to start it !! Also I
> wondered if I should be using lead fuel
> additive ?
> Thanks,
> Adrian

Do you use the choke when you start the thing? I almost always add a dab of choke before starting when its cold. And yes---you should definitely add some lead additive on your early Z.(according to my Z expert)

I use WD-2 lead substitute. One cap full per fill up...
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top