ZCar Forum banner
Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
I am having a little trouble diagnosing a problem I am having with my 280ZXT.
I changed the turbocharger so I had to remove both manifols and injector harness of course, and also the ignition.
This is not my first time doing this (if fact is like the 20th).
Here is the problem...
when I race the car up to 6000 rpm and shift to 2nd gear (fast) my car bogs, it looses (I dont know) current or fuel. I have to let go the pedal and when I loose some speed then the engine continues running ok (it takes about 4-5 seconds)

notes:
1. I've checked the timing (thought the timing was way off)
2. The car runs fine the 1st gear and all gears if I shift smoothly
3. Sometimes the car bogs when accelerating (just sometimes)
4. new spark plugs,filter, air filter is clean
5. I was having problem with one ignition wire but fixed it
6. the car idles OK
7. I cleaned all the electrical contacts in the computer and the engine compartment
8. I am running 15psi, thought it was too little fuel, reduced pressure and still the same
9. installed 2 additional injectors (no difference)

what may be the problem???????????
please help, I would like to have my car up and runnig for next saturday races. I am still waiting to fell the pull of the new turbo.

please help me if you know a possible cause

CarlosZXT
icq 1759272
[email protected]

BTW those darn BFG drag radial tires DO grip. I already broke an axle and hope I'll be able to remove it tomorow.
that is part of the price of wanting and having a fast car.
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top