ZCar Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
For some reason, after my car has warmed up my oil pressure drops when it is at idle. My gauge is showing it to be around 5-15 lbs. Is this normal, or is it going to cost me another $800 like getting my exhaust leak fixed did?
 

·
Registered
Joined
·
996 Posts
It is normal for oil pressure to drop at idle. I've read that it should climb approx 10 pcs for every thousand rpms until it reaches max. If your oil pressure on a warm engine reaches 60 psi, you probably have nothing to worry about.
I've read that the sending units on the Z's and ZX's are prone to failure and will often read low. You may have this problem but I know of no way to diagnose the issue without replacing the unit and, one its replaced it doesn't matter if the old one is defective or not.
My oil pressure drops to at idle as well but the gauge is not calibrated with any meaningful scale so I have no real idea what it is at idle. I know the gauges are not very accurate so I rely more on them as an indicator rather than a measurment device.
Dan
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Well, i fixed the problem of the low oil pressure. Problem was mainly that my car was idling too low, around 4-500 rpm in drive. Now its around 9-1000, and oil pressure is around 25. Yay. And the reason my exaust leak was so much is a long story. If you are interested, here it is:

My dad and i tried to fix the exhaust leak coming from the first cylinder, and that turned out to be a total bust. My repair manual said to take everything off from underneath, but you had to take the intake manifold off too. And lots of the exhaust components were stuck together. So I took i to a reputable, and average priced import mechanic in the closest large town (Lake Jackson, TX..about 25k pop.) and had them deal with the headache. It took a week while they worked on other cars too, and they had to fabricate a lot of things because some bolts had been broken off in the head (my dad and I thought there were just missing), and my exhaust elbow after the turbo had been stuck together along with some other things. Well, they took care of all of it, and put the new gasket in. $450, ouch. But well spent considering all the things they had to do to it. Well, two days later, it rains @!#$ on me. The leak is back, worse than before! so I take it back to them, and we find out the manifold got warped a bit. So I forked over 250 for a manifold, special order from dealer, and got it installed with only $100 labor (they weren't going to screw me over and charge me the $500 it normally runs). So the grand total for this little escapade, which i payed out yesterday, was 378. So I got to waste $800 on the exhaust system in one month...and i've only had the car for 3.

Well, thanks for letting me get that out of my system.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top