ZCar Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 260. Bought it new and had it since then. Car set up for 2 years. After that it has not run right. Before then, it ran perfect. The problem began by pouring gas out of both carb vent tubes. Bought 2 kits, floats and power valves and had a guy who says he used to work for nissan rebuild the carbs. Since then it is no better. In fact it is worse at times. It still runs good when the operating temp is cold but when it reaches a certain temp. it goes crazy. It stars to cut out and goes dead when it is sitting still. I will welcome any suggestions to remedy this problem, however I do want to keep the car original.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Re: Obieport ! Do You Copy ?

AL 260Z. Out of all the things that you have mentioned, what is the most likely to cause the carbs on my 260 to load up with gas and then have gas coming out of the vent tubes on the sides of the carbs. And do you know anyone that you'd recommend rebuilding these carbs to factory specifications. Or where I can buy a set of factory rebuilt ones. As I said before the carbs ran just fine for 20 years, then because of a health problem I had the car set up for 2 years and it has been doing this ever since. I had 0 problems with the running of this car before and it has always been maintained. Frustated!!
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top