ZCar Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

· Registered
Joined
·
2,280 Posts
all of the above!
Pull the fuse box out and resolder all connections, usually under the ashtray or under the radio.
Replace all fuses, and try again
Relays are under the steering wheel or under the glove box.
Also check the connection tothe headlight, the connectors are not of the best quality (in front of radiator, under grill) if you have good voltage there, try the link to the headlight pod itself.
If your altanator is not charging full capacity, that will also effect the headlights
 

· Registered
Joined
·
948 Posts
The switch itself has contacts inside that are prone to carbon build up. I had to drive all the way across country with no headlights (I was able to jump the connection to make them work). Got home and took the switch apart ( love the old rebuildable components) cleaned the contacts.... still works a year and a half later!
 

· Registered
Joined
·
158 Posts
I've got the same problem, no headlights. One blinker works, and when I flip on the switch to the headlights, one blinker light comes on (doesn't blink though) and stays on until I turn the headlight switch off! Matter of fact, speedo and boost are the only guages that seem to work. Fuse box in front of the gearshift looks fine, but lots of the fuses have 'curled' links in the glass but they appear to be intact, don't know what that means. Also, there is no layout of what slot holds what fuse, and the amp rating. What the??? I got under the dash and unhooked-reconnected every wire connection I could find. Wow, now the horn works. They all look good, but how does one clean those little contacts?
 

· Registered
Joined
·
158 Posts
I have no idea. My fusebox is in front of the gearshift on the console, under a panel which has a few switches (for defog and choke) under the panel, so nowhere to put a diagram there. And, if I unscrew the fuse panel and flip it over, there is also the wiring on the underside of that. Aha! Maybe there is supposed to be a cover under the panel, but on top of the fusebox that I am missing?
 

· Registered
Joined
·
1,298 Posts
The fuse panel that you mention is only the lower half of the panel. The top half is the Clear Cover with the Fuse ID chart printed / embossed on it in white paint.

Sorry, don't have one handy to tell you what they read. I'll look and see if I can find a picture.
 

· Registered
Joined
·
320 Posts
Re; here ya go fusebox layout 240z

looking at fusebox from drivers seat..... LEFT SIDE 20amp a/c ---top fuse. second one down 20amp--wipers, third one down--20amp. flashers/ignition.. fourth one down---10amp.-horn....fifth down--20amp-stoplights...RIGHTSIDE:: top fuse=10amp-leftside headlight.. second fuse=10amp-rightside headlight...third fuse down=20amp parking lights...fourth fuse down =10amp dome light/ gauges..and fifth fuse down=common (i have know idea what they mean by common fuse) hope this helps you michele
 

· Registered
Joined
·
158 Posts
Re: Re; here ya go fusebox layout 240z

Lucky me! I found the cover in a small box of extra parts that came with the car. And it matches your description perfectly. Thanks!

Kurt
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top