ZCar Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So I have a 79 280zx my rear brakes randomly lock up can’t figure out what is causing this problem was also thinking of doing a rear brake conversion can anyone help?
also can’t find a brake booster master cylinder or calipers for this year smh
 

·
Administrator
1983 280ZX Turbo
Joined
·
2,270 Posts
Some thoughts occur to me:

1) Are the parking brake cables or mechanism binding?
2) How long since you flushed the brake fluid?
3) Are you sure it's not caliper pistons sticking (because of old brake fluid and corrosion)?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Some thoughts occur to me:

1) Are the parking brake cables or mechanism binding?
2) How long since you flushed the brake fluid?
3) Are you sure it's not caliper pistons sticking (because of old brake fluid and corrosion)?
it currently has new brake pads and new brake fluid I bled the front and back and just ordered new brake lines i also took apart the rear calipers cleaned them checked the e brake
 

·
Administrator
1983 280ZX Turbo
Joined
·
2,270 Posts
it currently has new brake pads and new brake fluid I bled the front and back and just ordered new brake lines i also took apart the rear calipers cleaned them checked the e brake
That all sounds good. When you say "cleaned," did you completely disassemble the cali9pers and replace the seals on the pistons?
 

·
Registered
Joined
·
2,621 Posts
Are you sure you checked the E-brake? they could be stuck or seized even when the handle is down. happened to my 280z.... had to pull the little hat pin out to get it to disengage. Just a thought.

Bon
 

·
Registered
Joined
·
4,579 Posts
A blockage of the return port in the master cylinder can cause this as the brake fluid heats up.
 
  • Like
Reactions: johnh240

·
Registered
Joined
·
4,579 Posts
Keep in mind that the return port is blocked if the piston is not moving all the way towards the rear of the car when the brake pedal is released.Sometimes this is just an adjustent issue. If the piston does not go back fully and uncover the port when the brake pedal is released, then the brakes will lock up when they get hot.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
I replaced the rear brake hose and bled them and everything works good again I also took the caliper apart inspected everything it was all good seems like it was just a bleeding error lol smh
 
1 - 9 of 9 Posts
Top