ZCar Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So I'm still stuck with the alternator not charging. Attached are pics of troubleshooting areas I've covered:
New alternator with wiring per pic. Straight forward wiring but at this point could I have something ass backwards?

Brake Warning Relay under the passenger seat. I tested with my multimeter and no open present. Condition of the relay looks very good.

16002008359343545045948694864704.jpg
16002008917386223504269665605408.jpg
1600200960948521688369992528704.jpg
Fusable link in pic is fried. Not sure what this controls but I do plan to upgrade these fusable links once parts arrive.

Car starts and runs well though I only have about 100 miles on thus far.

Any viable help is welcome.
Jeff
 

·
Registered
Joined
·
834 Posts
Non-engine electrical stuff would be connected to the fuse box near the passenger foot well. The fusible links are strictly for engine and wouldn't be affected by stuff like that. Take a look at the factory service manual's "engine electrical" chapter - it is available here: XenonZcar.com S30 Factory Service manuals.

Since you have a 1978 and just got a new alternator my guess is you bought an alternator which requires an external regulator. Our 1978 cars are the only s30 year that uses internally regulated alternators.

Head back to your parts store and get the 280ZX alternator - that is the one you need. If you got that, you may just have a broken alternator - these are rebuilt and are known to have issues (I went through 3 of them at oreillys before I found one that had all the parts working.

Blowing the links (especially the black wire which is the charging circuit) happens when you install a broken or incorrect alternator.
 
1 - 2 of 2 Posts
Top