ZCar Forum banner

‘78 280Z Intermittent Stalling - I'm out of ideas (long)

15101 Views 19 Replies 9 Participants Last post by  Arubabill
The car:

I have a 1978 Datsun 280Z that is plagued with intermittent stalling problems. The car is equipped with a 1978 fuel injected L28 engine. The ignition system was rewired and upgraded with 1979 -80 280ZX components (distributor, ignition module and coil assembly replaced). In addition, the cold start fuel injector has been removed and the fusible links replaced with standard auto fuses.

The problem:

The engine is more likely to stall when it’s warm, but this isn’t always the case. It may be 3 minutes or several hours, but eventually it will stall. When it’s about to stall, I can sometimes save it by keeping the accelerator buried. It will cut in and out, run very rough and very rich (lots of smoke). If I can keep it going long enough it will eventually smooth out and run normally. This usually takes between 30 seconds and a couple of minutes. If I can’t keep it running and it does quit, it acts like it’s flooded and no amount of cranking will restart it. In the past, the only way to restart it was to pull the plugs and dry them off (or wait an hour). After they were dried, it would usually start and run fine. Lately however, even drying the plugs won’t allow a restart. If you dry the plugs and hit the starter, it will fire and then immediately die. I’ve found the only way to get it to run, is to partially disconnect the rubber boot between the AFM and TB (I release the clamp and slide the boot half way off so that some intake air goes through the AFM and some directly into the throttle body). Once it restarts (with the AFM disconnected), it will continue to run if you keep the accelerator to the floor. Again, it will run very rough and then all of a sudden improve. Once it “clears” I can reconnect the rubber boot and it will start and run normally (until the next time it stalls). I’m certain this is a major clue as to what’s going on, but I don’t have sufficient knowledge of the AFM – TB – ECU interaction to make any sense of it.

Obviously, something is wrong, but in spite of my best efforts, I can’t figure out what it is. I’ve read all the post I can find relating to similar problems, completed all of the recommended troubleshooting steps and still come up empty. The following paragraphs provide some detail of the steps I’ve taken (sorry for the length).

The troubleshooting steps I've taken:

I’ve checked / replaced connectors from the water temp sensor, throttle position sensor and AFM. I’ve also check all of the grounds that I could find, as well as the bullet connectors (cleaned, replaced or soldered). Using an ohmmeter, I’ve checked all of the sensors at the ECU connector, as per the FI Manual – all normal. The fuses and relays test good. I’ve confirmed that the throttle position sensor is working and properly adjusted. Finally, I verified that the water temp sensor isn’t the problem (I replace it with a known good spare).

As far as I know, there are no vacuum leaks (if I disconnect one of the vacuum lines the engine RPM increases) and the aux air regulator seems to be working.

Finally, the fuel pressure is correct and the injectors are all working. The timing is within a couple degrees of spec. The spark is strong and blue.

Short of spending a ton of money and replacing the AFM, ECU and ignition module, I don’t what else to try. I’ve obviously missed something. I’m hopping that someone might be able to point me in a new direction.

Thanks in advance for your help!
See less See more
Not open for further replies.
1 - 20 of 20 Posts
Take cover off AFM watch the counter weight . Make sure it returns
all the way. Flapper in the AFM might be sticking open.
It might not stick all the time.
Is the Check Valve at your fuel pump clogged ? When it stalls does it feel like fuel starvation or electrical paralisis ? The dizzy you now have is from a 79/80 ZX you say ... is it the 1280 Distributor with the ignition module ? If so, after installing it did you bypass your (a) transistor ignition unit at inside passengers footwell and (b) your resistors at drivers fendew well below the Coil ? Have you installed a new fuel filter ? As it begins to stall is your Tach racing and then drops dead or does the Tach simply drop dead ? Have you removed your Steering colum plastic to know that ALL conections are tight and secure and where they are supposed to be ? How large an amperage did you go with your 'automotive glass fuses' that you chose to replace your former fusible links with ... 20amp ? 30 amp ? Greater ? Are these glass fuses getting bounced around not maintaining a solid fix for electrical conductivity ... if so this is the reason the Larger 50amp to 80 amp fuse blocks are used ( look at www.atlanticz.ca and their Tech write up on this style fuse block and fuses ) . When you mention 'upplugging' your AFM are you stating that the electrical plug at its bottom is disconected ? Is your AFM grounded by a ground wire to the chassis ? Have you pulled your valve cover and checked for too tight a intake valve thereby not allowing air into the combustion chamber for ignition. Is this 'stalls' problem only at low speeds ? Only at lower RPM's Does your vehicle stall at speeds above 40 mph ? As you can see there are too many questions I have got that inhibit me from presenting to you a clear and easy answer. Please re-post on the answers to some of these and maybe I and others will more clearly understand what may actually be happening to offer some constructive opinion and advice. BTW ... at the www.atlanticz.ca site their is a PDF downloadable S-30 280 Nissan Fuel Injection Service Manual that has just about every concievable troubleshooting problem that can occur . If nothing else this manual may give you greater insight as to a real solution for your current problem. Goodluck.
See less See more
I would check the cts. Did you retain the thermotime switch when you got rid of the cold start injector? If you still have it in the thermostat housing,the next time the car stalls,switch the cts and thermotime connectors and see if the condition improves somewhat. My 78 was acting similarly awhile back and I switched the connectors and it ran well enough to get me home then installed a new cts and so far ,no new problems.
Thanks for all the suggestions. It looks like I have some homework!

I did check the flap on the AFM and it does not hang up. While I had it out of the car to remove the cover, I also carefully checked it with an ohm meter for any dead spots, or erratic behavior. It checked fine. The only thing I’m not sure about is the air temp sensor. It measured approximately 2,000 ohms at room temperature, but I don’t know if this is correct.

The fuel pump was replaced at some point, before I purchased the car. It is not stock 280, but seems to work normally. I’ve confirmed that both the dead head pressure and pressure at the fuel rail is correct and remains so, even when the engine is running rough. From this I conclude that the pump and regulator are doing their job.

I’m 90% certain that the problem is electrical in nature. The distributor is from a 280zx and includes the ignition module. The stock 280z ignition module was bypassed and removed, as was the ballast resistor. I’ve also replaced the ignition module on the distributor with a new one. Just by chance, I was checking for spark (using a spark gap tester) today, when the engine stalled. I was able to confirm, that even when the engine stalls, the coil produces a strong spark as long as the engine is rotating. Correct me if I’m wrong, but I think this would rule out the entire ignition system, including the switch, as a source of my problem.

As far as the tach is concerned, it is not erratic and does not race, or jump around when the engine stalls. It just follows the actual RPM. I have seen this on a BMW motorcycle, due to a failed Hall Effect sensor on the crank. This is not what’s happening here.

The fuses used to replace the links are the high amperage plastic tab type fuses. The installation is similar to that specified at http://www.atlanticz.ca. In fact, the distributor upgrade also follows the instruction given at the Atlantic Z site.

As far as “unplugging” the AFM, I did not mean I removed the electrical plug. I was referring to the rubber coupling that goes between the TB and the AFM. In other words, intake air bypassed the AFM and went directly into the TB. The AFM was not grounded and in fact I found the short black ground wire had been disconnected. I reconnected it, but unfortunately, the problem persists.

The problem occurs at all speeds and does not seem to be RPM sensitive. The best way I can describe what’s happening, is to equate it to what would happen if you were running out of fuel. In fact, at first I was sure it was a fuel problem, but I’ve pretty much ruled that out, because the fuel pressure is good even as the engine is stalling.

I have confirmed that the problem is not the CTS. I did this by temporarily substituting a 330 ohm resistor for the sensor. I also installed a new Bosch connector at the CTS and got rid of the old bullet connectors. This did not solve the problem.

I’m starting to think that the ECU itself may be defective, or that the connector is intermittent. I’ve never had it apart, so I don’t know what type of components it uses. If it contains electrolytic capacitors, these are prone to drying out over time and could cause it to fail. I’ve seen this happen in other vintage electronics and in fact, it’s fairly common. I've also seen situations where solder joints between connectors and printed circuit boards fail, causing intermittent connections. I think checking out the ECU may be my next adventure in 280z troubleshooting!
See less See more
Re: ‘78 280Z Intermittent Stalling - I'm out of ideas - Found the problem???

Even though I've checked it before, I thought I'd check the ECU / connector one more time. What I found was that if I press hard on the large AMP connector, the engine will settle down and run smooth as silk. Also, if twist it just right I get the same result.

The first thing I did was to spray it with contact cleaner and make sure that there was no visible corrosion. I then removed the cover shell on the connector and confirmed that all of the wires are firmly attached to the pins. In fact I plugged it back into the ECU with the shell off, started the engine and then wiggled each individual wire. This had no effect, so I'm fairly certain that the connector wiring is good. I put the shell back on, reconnected the ECU and tried it again. Unfortunately, the problem was still there. Moving on, I removed the ECU from the car and took it into the shop. I opened it up and checked the solder joints, where the connector attaches to the PC board. They all looked good, but as long as I had it open, I touched up each of the joints anyway. Everything else looked fine.

I reinstalled the ECU and reconnected everything with high hopes for success, only to be disappointed; same old problem. The problem is either a bad pin/s on the 38 pin AMP connector (even though they all look good and tight), or pushing hard on the connector is flexing the ECU PC board, reveling a bad solder joint or a broken trace. I might try and track down another ECU and see if it corrects the problem. If not, then I can look forward to installing a new connector, assuming I can find one in good shape. I'm hopping for a bad ECU, because the thought of rewiring the connector is less than thrilling!

Thanks again everyone for the suggestions. I let you know how it comes out.
See less See more
SURE! All those connector contacts look new BUT they are over 30 years old. Spray them with your "contact cleaner spary" and THEN jam them together a few times and see how it goes. "One dead pin on your ECU connector could mean one dead z car." In fact, they do say to disconnect the battery and then clean EVERY CONNECTOR and connection and clean it good, then reconnect the battery. Some of these connections are low current BUT very important. IS your fuel pressure really "constant" when all this stalling takes place? Norm K.

I know you're correct when it comes to the connector pins being 30+ years old. I just don't want to think about! I've already gone the contact cleaner route without much luck. They make very fine, narrow contact files and that may be my next step. If it's a corrosion issue that should take care of it. I've also found a guy (a friend of a friend) who has a spare ECU that I can try. I'm going to pick that up tomorrow and see what happens.

Do you know if new connectors are available? If I have to replace the connector, I'd sure hate to go to all that work, installing a used connector, just to find out that it's no better than the one I'm replacing.

As far as the fuel pressure when stalling goes, it's not constant, but it's not significantly different than stopping the engine normally.
See less See more
Well ... Please read this completely before doing any of these modifications ..... Very good for you to continue to do the work you have done on your ZX without having given up the hope that it WILL run right . Okay, at this point I am thinking since I will agree with you that this problem is Electrical in nature is that your current fuel injector relay module has failed. The replaced fuel pump unit to need to observe it actually spurting fuel out of your engine bays fuel filter. Again, disconnect that top fuel rail line going into the fuel filter and put that fuel hose into a glass jar. You or an assistant then crank your engine and with the ignition key in the "running" position observe and note for how long your fuel pump runs fuel into that glass jar. It is possible that the Cold Start injector is doing its job but that afterward the continuous flow of fuel from the fuel pump simply is NOT happening due to failed fuel injector relay module. Without a 'good' module the fuel pump will NOT run unless bypassed. In fact I will suggest that you bypass this injector relay module altogether forthe time being simply to isolate it as being part of your current problem. To do this first look at your ZX's oil sensor on your engines block. It should be a 2 wired unit. One wire leading to your in-dash oil gauge and the other to your fuel pump relay and onward to the pump. So ... (a) Remove this wire clip. Now jack up your vehicle and at the fuel pump determine which contact leads are the Pos and Neg. (b) You'll now attach alligator clips to these leads. The Pos lead you will run to the battery with a in-line 30amp fuse and a two-prong rocker switch. The Neg lead you will secure to a good chassis ground. The rocker switch can be 3 or 2 prong. Best would be a 3 prong ... Load from fuel pump to "Load" prong. Ground to a ground nearby inside chassis or outside at "Ground" prong. And Battery lead with fuse to "Battery" prong. Now ... having done all this you are bypassing certain safety designs in case your car flips over or has an accident because only flipping the rocker switch will turn your fuel pump off. Okay ... turn rocker switch on . (c) Determine you are getting fuel OUT into that glass jar from your fuel filter. (d) Re-connect that top fuel line from fuel filter to top fuel rail. (e) Sit in car or have assistant sit in car.... turn rocker switch on ... wait the customary 4 to 5 seconds for the L-28 engine to be 'energized' with fuel ... turn Ignition key to 'ON' and crank engine for a second or two. Now ... Is engine running ? If so ... let engine run and idle while after some moments you increase your Revs to 4thousand lets say for a few moments. After idling again turn everything off. Now re-start ZX and go drive around the block.
Did it stall on you ? If not then its your fuel injector relay module for certain that is the culprit to be replaced. So replace it ... put Oil and fuel pump wires back onto Oil sensor at engine block. Remove aligator clips and all rocker wires and in-line fuse. You should now be good to go.
The last question I will have you address is this : What was the last thing to have happened (perhaps you were changeing something or working on something) before this current Hesitation and stalling problem began. Was it always this way ? Is this a recent purchase for you or have you driven this ZX for some time and only recently has this problem been occuring ? Goodluck.
See less See more
Man, these are all great suggestions. Very knowledgable.
What I've found on most of the Z cars I've had are relatively simple solutions to nagging probs like this. I'd definitely go through the basics one more time — timing, filters, solid grounds, etc. I would also look at easy-to-overlook items like the ignition switch itself (do you have a heavy blob of keys hanging from it?), and the safety cutout system for the fuel pump. In the early fuelies, this was like a seventh pin or so in the AFM. So if you have a seven-pin AFM, it might be one of those. But I think by 1978, you might have a five-pin AFM plug, and the safety cutout was part of the oil pressure switch circuit. If you have two wires going to the oil pressure sensor, that's it. (Not sure of when this changed, it's been awhile). If it's the latter, one of those wires is for reading oil pressure, one is for sensing loss of oil pressure (such as in an accident), which will cut out the fuel pump so you hopefully don't get barbecued. Make sure both those wires are clean and on there good and solid.
Good luck. Let us know when you finally ID the prob.
Also, as Shane pointed out, let us know if this is a new problem or old. Did it do the same thing, for example, with the 'old' original '78 dizzy?
See less See more
Hey guys, thanks for all the great suggestions. I think I have finally found the problem and corrected it, or at least I hope so! As I mentioned a couple of days ago, I localized the problem to the ECU or ECU connector. I found a guy in the area who had a good working ECU out of a '77 280Z. I finally got a chance to drive out and pick it up this afternoon. When I got home the first thing I did was unplug the old original, install my new find, cross my fingers and hit the starter. SUCCESS!!! The engine started without hesitation and ran as smooth as ever. No matter how I wiggled the connector, or shook the cable, the engine didn't miss a beat. Just to be sure I had really solved the problem, I plugged the old ECU back in and within 30 seconds the engine stalled and refused to restart. When I plugged the new one back in, it came to life with virtually no hesitation and continued to run for nearly half an hour without missing a beat.

Clearly there is something wrong with the original ECU and it's mechanical in nature, in other words, it not a bad component, but rather a bad solder joint, or a broken trace on the PC board. As I mentioned in a previous post, if I twisted the big 38 pin connector just right, or if I pushed it in really hard, the engine would run smoothly. I suspect what I was doing was slightly flexing the PC board inside the ECU, causing an intermittent connection. I've already touched up all the solder joints where the 38 pin male connector mates to the PC board, but apparently that's not the source of the problem. As I'm writing this, I'm thinking another likely culprit might be the connection between the power transistors that drive the injectors and the PC board. The transistors are rigidly mounted to the outside frame of the ECU (to provide a heat sink) and any flexing between the PC board and the metal frame could easily cause one of the solder joints to fail. Over 30+ years, even the thermal stress caused by the heating and cooling of the transistors could cause this type of problem. At this point, I guess it's rather immaterial whether I can fix the old one or not, but I like puzzles and this is a puzzle that needs solving.

To anyone reading this with a similar stalling problem, my advice would be not to discount the ECU as being the source of your problem. I'm sure it way down on the list of possibilities (bad grounds and connections being number one) but when you're out of ideas and you've tried everything else, consider swapping in a replacement ECU. You might save yourself a whole lot of time and frustration.

The upside to this whole adventure has been that I've learned a lot about how EFI works and in particular, what makes the 280Z tick! One more thing I've learned, is that there are a lot of very knowledgeable people, on this board and others, willing to help. Thank you all!!!
See less See more

Also,ECM are year and application specific.In 78 the ECM for a Fed car will be different than a 78 California car.Check part numbers!

If you follow the above instructions,yours is easily repairable.
Arubabill is right on the different ECUs for 77 and 78. Even worse though, Datsun used the same part number through 1978 even though they changed the internals for the 1978 ECU. Compare the pins on the 77 ECU to those on the 78. The 78 ECU's pins don't even match the 78 FSM diagrams completely. I tried a 78 ECU, same part number, in my 76 280Z and it sounded fine and ran well but stalled about 1 mile from the house on a test drive and wouldn't stay running after that. If you get a 78 ECU that matches the pins on your current one you should be okay.

Or you can try to fix yours. Here is a thread about bad solder joints and how to fix them - http://www.classiczcars.com/forums/showthread.php?36903-280Z-ZX-ECM-tech&highlight=ECU+solder
I’ve already reflowed all of the joints relating to the 35-pin PC board connector. I did the same to the two power transistors connection points, as well as any other joints that looked suspect, all with no success. As I stated in an earlier post, I’m certain the problem is either a bad solder joint, or a broken pad / trace, both of which can be caused by mechanical flexing. Although everything looks OK, my guess is that there is a break between one of the solder pads and the trace, probably at the connector. The easiest fix for this is to bridge the joint (solder pad to trace) with a small piece of wire. This is a common fix and easy to do, especially with simple, single sided PC boards. I’ll get to it eventually, but in the mean time, it was just easier to install a different ECU.

As far as the ECU’s being functionally different, I’m not sure that’s the case. I researched several sources and they all indicate there is no functional difference, as long as the part number is the same (A11-600 000 in my case). What may be confusing is that there were subtle differences in the way the ECU’s were wired in ’78. For example, Z’s prior to 1978 had a fuel cut off switch on the AFM that was wired to the ECU (pin 20). In 1978 this was abandoned in favor of a system that monitored the oil pressure / alternator output and did not connect to the ECU. They just left pin 20 on the ECU floating, but the ’78 ECU still has pin 20 connected to the PC board. I suppose there could be some mapping differences, but again, nothing I've read indicates that’s the case. That said, I’d appreciate it if you could point me to any sites that discuss the differences between ECU’s and might even contain schematics. I’ve found that information on the internal workings of the 280 ECU is extremely difficult to obtain.

As it is now, the ’77 ECU is performing perfectly, so I’ll keep my fingers crossed that it stays that way. :) By the way, my ’78 is a federal / non-Cal. car.

Thanks again for the help.
See less See more
All part numbers being the same,then the unit SHOULD work.However,i know for a fact that there is diffeences between 77 & 78.
Thanks for the feedback on how well the engine is running with the 77 ECU. I might have a bad 78 ECU, it ran fine on a parts car in the garage but not under load on the 76. The differences that I found in the wiring were all FI relay and CSV related, plus the 78 FSM shows a pin for the CSV that doesn't exist on my 78 ECU. I ended up with the same conclusion as Arubabill, there is a difference, but haven't been able to find out for sure why Datsun did what they did. The changes are significant enough for a new part number, but they didn't give one. I haven't owned Zs long enough though, to have experienced more than a 76 and a 78 car.

The best schematics for the ECU to engine harness are in the Engine Fuel sections of the various FSMs. One page with all ECU pins and components shown.

Good luck with the car. You sound like you know what you're doing.
See less See more
Amazing how 10 hours of sleep will help you see things better.BMUU-if you problem was fixed by pulling/pushing the main cable to the ECM,then there are bad solder joints.You say you looked and found nothing "out of sorts".Either look again closer or take it to a "Electronics guy".THe culprits more than likely wil be the 90 degree pins that land on the board.
Hmm, darn, I didn't expect an even worse problem of "old cracked solder joints" or cracked circuit board. MOST of these Zs just need cleaner connections. (Sometimes when a NEWER CAR has no outer brakes lights but the center light is OK, it's due to a circuit gets melted or has cracked solder connections. Just add solder! By flexing a circuit board under a magnifying glass you can see the cracks "big and boldly!" I once successfully repaired a circuit on the back of a color TV that a "workout weight" dropped on. If I was you I would take a closer look or send it to the "electronics guy." Take a good look first. Norm K.
I have been reading this post about the ECU.I have been running a ECU from a 83 Maxima since I bought it in 94.Meaning it was there when I bought the car.
zcarron said:
I have been reading this post about the ECU.I have been running a ECU from a 83 Maxima since I bought it in 94.Meaning it was there when I bought the car.
You're lucky.The Maxima ECM is for a L-24E,not a L-28

Norm,i found three joints on my ECM board that had failed.I reflowed all of them and and no issues since.I had the same issue,where i would push or pull on the ECM cable and that would kill the car or make it run properly.
1 - 20 of 20 Posts
Not open for further replies.