ZCar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 70-83 Tech Discussion Forum
    Hey y’all! I’ve been working on a ‘73 240z the last few months, figuring out different issues to get the car running right. Today after, after sitting since Monday, when we went to start the car, it ran great, on all 6 for the first time, but it was reviving upwards of 2600rpm as soon as it...
  2. 70-83 Tech Discussion Forum
    So I am at a loss in trouble shooting this problem and would like some advice. The car is a 1980 280zx NA. The short version is I bought the car in a no start condition, the only thing the guy I bought it from could say for sure was if you turn the crank manually it was able to turn freely. I...
  3. 84-89 Tech Discussion Forum
    Hello everyone, new here to the Z car website. I have a 1987 Nissan 300ZX naturally aspirated engine. I just rebuilt the motor on it with new internals and parts. I went to go fix the timing on the engine last night but the car will not start. It used to start before but now it refuses to. I...
  4. 70-83 Tech Discussion Forum
    Hey I’ve gone through out the whole car and replaced the whole ignition system before this just to get avoid any future problems along with the fuel system and the air flow meter and the car ran like a top, I then had to replace the oil pan gasket and decided to replace the oil pump for...
  5. 70-83 Tech Discussion Forum
    So i have another dilema. I am working on a 1982 280zx(L28et). I have not had this car running since I started repairs. I replaced the distributor and distributor shaft but made a rookie mistake and didn't take a picture or mark where the rotor head was at. I have now rotated the engine crank...
1-5 of 5 Results
Top