ZCar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 84-89 Tech Discussion Forum
    Hey guys, I hope I am not being too annoying with my posts. Just been running into issue after issue with my Z31 and this time I am stumped and don't know what to do from here. My car was working fine one day, then I went to start it but I get nothing to the starter. When I turn the key to the...
  2. 84-89 Tech Discussion Forum
    Hey guys here is the situation: Drove my Z31 just fine this morning. Everything started up, sounds fine, nothing out of the ordinary. Went to go park somewhere on my lunch break from work. Got done doing my thing then went to go start my car but it won't start now. Between driving from work to...
  3. 70-83 Tech Discussion Forum
    Well, this should be easy enough to describe. My 1981 280ZX is having a bit of a starting issue. At rest, the vehicle usually hangs out around 14 volts. When I turn the key to run. The starter sounds like it turns over once normally and then becomes haggard and battery voltage drops down to...
  4. 70-83 Tech Discussion Forum
    Can you prime a z engine using the compressor method or does it only work with the drill priming method, I’ve been trying to prime mine but don’t seem to see any oil come out the oil rail in the head
  5. 84-89 Tech Discussion Forum
    I was driving the car all day like normal and when i had parked and left it for no more than 20 minutes. When i got back in it, it wouldn’t start. It cranks but there seems to be no power to any gauges lights anything. Normally you can hear the fuel pump activating and such but now when you turn...
1-5 of 5 Results
Top