ZCar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 70-83 Tech Discussion Forum
    Hello, I have recently undergone starting my 1975 Datsun 280z. The past owner claims it was started and ran 1 year before I bought it, 2.5 years before today. So far I have: Replaced the battery Replaced the fuel pump and added pre-pump filter Replaced fuel filter Replaced all hoses Installed...
  2. 84-89 Tech Discussion Forum
    Hey guys, I hope I am not being too annoying with my posts. Just been running into issue after issue with my Z31 and this time I am stumped and don't know what to do from here. My car was working fine one day, then I went to start it but I get nothing to the starter. When I turn the key to the...
  3. 70-83 Tech Discussion Forum
    A couple questions regarding possible situations where fuel is not being delivered. To preface, I'm new to mechanics and whatnot my background is embedded systems. In regards to the electric fuel pump, when I turn the key there is no voltage at the electric fuel pump. Ive read some things about...
  4. 70-83 Tech Discussion Forum
    Hello! My name is Brochungo and I’m new to the board. I recently got a 1982 280zx for a decent price, the previous owner told me that it: had a new battery, new spark plugs, needed gas, and that the car was flooded when it drove in Seattle. I got gas, new spark plugs (haven’t installed them...
  5. 70-83 Tech Discussion Forum
    Hey I’ve gone through out the whole car and replaced the whole ignition system before this just to get avoid any future problems along with the fuel system and the air flow meter and the car ran like a top, I then had to replace the oil pan gasket and decided to replace the oil pump for...
1-5 of 5 Results
Top