ZCar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. 70-83 Tech Discussion Forum
    I've recently installed my 123ignition distributor into my 81 280zx, while doing so, I believe I shorted the entirety of the ignition harness from the coil back to the switch. When turning the key, nothing activates, no relays can be heard, the fuel pump does not prime, the engine does not...
  2. 70-83 Tech Discussion Forum
    Hi, I’m restoring a 75’ 280z. Finally got the engine in and running, but after starting the engine will not turn off unless I pull the coil plug from the distributor. I even pulled the ignition connector and the coil still has power whenever the batter is connected. Would a bad starter relay...
  3. 84-89 Tech Discussion Forum
    Hey guys, I hope I am not being too annoying with my posts. Just been running into issue after issue with my Z31 and this time I am stumped and don't know what to do from here. My car was working fine one day, then I went to start it but I get nothing to the starter. When I turn the key to the...
  4. 90-96 Tech Discussion Forum
    Hello I have 1993 auto z32 NA. Recently I did a tranny swap (auto to auto) and an injector change (270 to 270) as well as deleted my coolant lines under the plenum. I go to start the car and it starts. I do it a few times and she always starts right up. I then go to reverse her out the driveway...
  5. 70-83 Tech Discussion Forum
    The first tool is diagnosis by the appearance of your spark plugs. Down the page is animated vacuum gauges with explanations of what causes various readings and fluctuations. Then it explains all of the ignition components and how they work. (Points & electronic) Then it shows animated scope...
  6. 70-83 Tech Discussion Forum
    Hey I’ve gone through out the whole car and replaced the whole ignition system before this just to get avoid any future problems along with the fuel system and the air flow meter and the car ran like a top, I then had to replace the oil pan gasket and decided to replace the oil pump for...
  7. 70-83 Tech Discussion Forum
    So my electronic ignition module or Transistor Module is out. I tried to wire in a hei from a gm with no luck. For some reason i am not getting a signal from the pickup coils i have 2 in the distrubutor. A new pickup coil is non existant for my federal emissions setup. and a new distributor is a...
  8. 70-83 Tech Discussion Forum
    All Knowing Gurus of the Z, I recently obtained a 80' 280zx. It had been sitting for 8 years. It was parked and never drove or started since then. I did the usual, drain and replace fluids, new battery, new gas- bypassed the tank for now. check fuses. Turned the crank by hand. Checked TDC and...
1-8 of 8 Results
Top