ZCar Forum banner

Search results

1-16 of 16 Results
Advanced Search
  1. steering rack removal

    90-96 Tech Discussion Forum
    Thanks, did all that but did'nt want to take off that line on pass side.
  2. steering rack removal

    90-96 Tech Discussion Forum
    Like the title says, whats the easiest way of removing the rack. Its a 90, 300 non turbo. Can it be done without raising the engine?
  3. lower ball joints

    90-96 Tech Discussion Forum
    Guess, I'll have to take 'em off. I did try and fit it, but does not look right. Rubber looks like its gonna tear.
  4. lower ball joints

    90-96 Tech Discussion Forum
    What up guys? I just installed my lower ball joints, but I noticed they did not come with the metal cone that's at the top of the ball joints.Could they be installed with out them or not? I did a search, but did not find any body who has?I did see that Vigman took his old ones off, but can it do...
  5. tps...maf???

    90-96 Tech Discussion Forum
    hey guys, ok i got my z running good but, the only thing is that when i start it it'll start but only for bout a min. then die,if i leave my foot on the gas it'll stay on.it was giving me a code maf,but i sprayed some maf cleaner did not get it again. but still does it,and no codes but 55.my tps...
  6. electrical wire knowledge needed

    90-96 Tech Discussion Forum
    switch out your 8ga. wire with 4ga.wire and yeah,theres some cheap wire out there that really arent 4ga. but raptor is good not as good as kicker but it'll work.as for the wire to the alternator dont need it but could help,but u need a bigger alt..and your ground should be grounded to bare...
  7. fustrated

    90-96 Tech Discussion Forum
    yeah it still has it, its a reman from python thats what it says on the mafs. does any one know where i could get a new good cheap one?
  8. fustrated

    90-96 Tech Discussion Forum
    i bought some maf cleaner at autozone, sprayed it good let it dry, no green stuff on the mafs plug it self,my ecu harness is new.is there a way to test the mafs out of the car?
  9. fustrated

    90-96 Tech Discussion Forum
    alright, i posted a few days back about the o2 sensors gettin a code 33 [my left side] so next day check my codes to see if maybe the computer would reset and give me a code 55,but no luck now im gettin a code 12 [mafs],so now i dont know what to believe. cars gone nuts.any help guys? thanks...
  10. oxygen sensors

    90-96 Tech Discussion Forum
    i dont think the harness can be messed up.it has to be inside the sensor it self.
  11. oxygen sensors

    90-96 Tech Discussion Forum
    i just recently bought some ams o2 sensors from z1mt. so i installed them and now im gettin a code 33.=before i had a code 55.i assume both sides r the same. i did take off my egr could that b y? or is just bad out the box? has this happend to anybody?thanx.
  12. two filters

    90-96 Tech Discussion Forum
    When i start my 90z sometimes it makes a gurglin sound on my drivers side, so i took my wheel liner off and noticed the filter box and a valve connected to it, so i took it apart and noticed that the filter was wet, i went ahead and blew the water out and let it dry, put it back in and all fine...
  13. egr

    90-96 Tech Discussion Forum
    I was thinking about replacing my egr,but i see that theres block off plates for the egr? so my question is can i put those on my z even though its not a turbo? saves me money
  14. runs bad when it rains

    90-96 Tech Discussion Forum
    one mechanic said that it may be the mafs or the tps,but i dont understand y it runs when its not raining? & i've checked too see if they get wet & its not,so i dont know if its moisture,or what?
  15. runs bad when it rains

    90-96 Tech Discussion Forum
    does not have a pop charger,everythings pretty much stock,i did change the ecu wire harness & the ecu,i replaced the fuel pump still keeps doing the same problem & i dont see any wires that r bad.
  16. runs bad when it rains

    90-96 Tech Discussion Forum
    I,ve got a 90 300zx n/t m/t & when it rains the car will start to cut out & wont run.But when its sunny it'll run good.If anybody can help me where the problem might be or any close idea, i would appreciate it.
1-16 of 16 Results
Top