replace fuel injectors or poor voltage? - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-10-2019, 06:52 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry replace fuel injectors or poor voltage?

i just apprehend a `77 280z from my father. it has been sitting since 2001. hasnt run in last 5 years. replaced fuel pump and filter. i can get it to start for 30 seconds with started fluid but thats it. im worried that it could be the fuel injectors there is a pulse when we attache the noid light but it is very weak. does anyone have any ideas before i pull off the rail and replace in injectors?
Megan Montoya is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-12-2019, 03:31 PM
Senior Member
 
Join Date: Sep 2015
Location: Central FL
Posts: 853
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 199 Post(s)
do you hear them clicking with a stethoscope?
Dave M is offline  
post #3 of 4 (permalink) Old Today, 02:39 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
i have not, be we're going to pull the injectors and have them cleaned anyways. it needs to be done.
Megan Montoya is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old Today, 07:42 PM
Senior Member
 
Join Date: Sep 2015
Location: Central FL
Posts: 853
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 199 Post(s)
if they are not clicking you need to find out why, You should try energizing at least one of them, a 9v battery connected across the pins should result in a notable click. If it does and its not clicking when trying to start, then you have a EFI issue. Could be something as simple as a corroded wire, or a blown fuse link.
Dave M is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
poor, poor z (poor me) Quattropop 90-96 Tech Discussion Forum 4 06-06-2006 01:24 AM
Poor, poor car. Cache 70-83 Tech Discussion Forum 4 01-08-2003 09:49 PM
Poor, poor classmate in my english class justin81 with t-tops 70-83 Tech Discussion Forum 12 09-28-2001 02:09 AM
poor, poor 280zx... Unknown User 70-83 Tech Discussion Forum 0 12-24-2000 01:10 AM
my poor poor driveshaft and u-joint madcowz 70-83 Tech Discussion Forum 1 05-06-2000 12:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1