My oil pressure guage reads 0. - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 11-18-2018, 06:02 AM Thread Starter
Junior Member
 
Zia31's Avatar
 
Join Date: Oct 2018
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
(Thread Starter)
My oil pressure guage reads 0.

I caught it before engine over heated coming off the highway. Funny burnt smell,abnormal engine sound,and coolant observable all over the radiator. And blown coolant seal
Zia31 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-19-2018, 10:27 AM
Senior Member
 
bonfire79's Avatar
 
Join Date: Feb 2006
Location: Workin in the United Arab Emirates; Livin in North Carolina; Born and raised in Southern Utah
Posts: 2,240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 223 Post(s)
i'm not quite sure what you got going on here, but i am going to presume the cooling system went out and not your oil pressure system.
what do you mean by 'blown coolant seal" ? you mean radiator cap?

it sounds like your engine boiled over due to running hot or not having proper pressure. or one of your coolant hoses blew. something blew, or you had a total loss of coolant. maybe a blown head gasket. check your oil dipstick for milky oil.

good thing you gaught it and got off the road.

Bon

All the Gods, all the Heavens, all the Hells, are within you. - Joseph Campbell -

Pooja II ~ 1984 300ZXT 50th AE ~ 2018 - 2019
Pooja ~ 1987 300ZX 2+2 NA2T ~ 2012 - 2018
Suzanna ~ 1983 280ZX Coupe ~ 2010 - 2019
Alana ~ 1976 280z Coupe NA2T ~ 2008 - 2019
Dianna ~ 1980 280ZX Slick Top ~ 2001 - 2007
bonfire79 is offline  
post #3 of 5 (permalink) Old 11-24-2018, 07:11 PM
Member
 
Join Date: May 2010
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by Zia31 View Post
I caught it before engine over heated coming off the highway. Funny burnt smell,abnormal engine sound,and coolant observable all over the radiator. And blown coolant seal
I had the same problem. Change your oil filter no matter how new it is. Use a different brand than what you have in there now. Worked wonders for me.
caddo71 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 12-17-2018, 09:26 PM Thread Starter
Junior Member
 
Zia31's Avatar
 
Join Date: Oct 2018
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
(Thread Starter)
Its my radiator. For some reason the leak comes out from the top assembly. I managed to stop her from overheating by putting in gallon jugs of water evertime i stoped arpund town. I'm just going to replace the radiator. I already got the old one out it wouldn't make sense not to do it. And then the thermostat also. I wonder if I should do the water pump?
Zia31 is offline  
post #5 of 5 (permalink) Old 12-17-2018, 10:42 PM
Senior Member
 
bonfire79's Avatar
 
Join Date: Feb 2006
Location: Workin in the United Arab Emirates; Livin in North Carolina; Born and raised in Southern Utah
Posts: 2,240
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 223 Post(s)
Quote:
Originally Posted by Zia31 View Post
Its my radiator. For some reason the leak comes out from the top assembly. I managed to stop her from overheating by putting in gallon jugs of water evertime i stoped arpund town. I'm just going to replace the radiator. I already got the old one out it wouldn't make sense not to do it. And then the thermostat also. I wonder if I should do the water pump?
brother,

while its apart, replace everything now. the first thing that usually goes out on these dam things is the cooling systems (in my own experience)
not very wise to replace the radiator only and then a few months later have one of the FOUR main water hoses blow... or the water pump take a dump... or the thermostat get stuck closed, or the clutch fan go out, or the radiator cap fail, or one of the heater hoses break, or the WP belt snaps, etc,.

depending on the milage, ask yourself the following: how long have you had the car? what maintenance has been done to it do you know? how about the timing belt? if you can't answer these questions, then my advice would be this:

while eveything is out, replace the timing belt and the CHTS w/harness (if you're changing out the thermostat and WP, you might as well knock these out too because you don't want to have to go back in there), the radiator, the two upper rad hoses, the lower rad hose, the water pipe connecting hose, the radiator cap, the three belts, and make sure your clutch fan or electric fans are in working order. all these are available from rockauto or nissanpartsdeal

Both of my Z31's had the same overheating issues and this is what I did to correct them.... of course like I said these were the first to go out

Bon

All the Gods, all the Heavens, all the Hells, are within you. - Joseph Campbell -

Pooja II ~ 1984 300ZXT 50th AE ~ 2018 - 2019
Pooja ~ 1987 300ZX 2+2 NA2T ~ 2012 - 2018
Suzanna ~ 1983 280ZX Coupe ~ 2010 - 2019
Alana ~ 1976 280z Coupe NA2T ~ 2008 - 2019
Dianna ~ 1980 280ZX Slick Top ~ 2001 - 2007
bonfire79 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Guage Reads 3/4 when full zwalker 70-83 Tech Discussion Forum 3 04-18-2005 10:10 PM
Oil pressure gauge reads with the ignition on. dexter260z 70-83 Tech Discussion Forum 2 07-09-2003 06:45 AM
fuel guage reads 1/4 even when empty AUZZIE 70-83 Tech Discussion Forum 4 03-17-2002 08:17 AM
280 gas tank, 240 guage, reads 1/4 tank when empty Unknown User 70-83 Tech Discussion Forum 1 05-25-2001 12:18 AM
300zx oil pressure reads zero and sounds like crap Unknown User 90-96 Tech Discussion Forum 4 01-12-2001 08:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1