New to z31 need help with strange hesitation - Page 3 - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

Reply
 
LinkBack Thread Tools
post #21 of 46 (permalink) Old 09-18-2014, 01:04 PM
Senior Member
 
Join Date: Feb 2010
Location: Oregon
Posts: 3,785
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 706 Post(s)
Quote:
Originally Posted by BettyismyBit View Post
The throttle valve switch, from what I remember, just kicks the throttle up a bit to warm the car up, and drops it down once it's warm.
This is wrong.
pdx280 is offline  
Sponsored Links
Advertisement
 
post #22 of 46 (permalink) Old 09-18-2014, 01:42 PM
Member
 
Join Date: Nov 2013
Posts: 86
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Garage
I just looked it up, I was referring to the idle up solenoid. My mistake. The part you are talking about is a throttle position sensor when talking about any other car. That would definitely cause your problem if it is actually faulty.

1984 300ZX N/A Automatic
130,000 Miles
BettyismyBit is offline  
post #23 of 46 (permalink) Old 09-18-2014, 07:45 PM Thread Starter
Member
 
Join Date: Dec 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Quote:
Originally Posted by BettyismyBit View Post
I just looked it up, I was referring to the idle up solenoid. My mistake. The part you are talking about is a throttle position sensor when talking about any other car. That would definitely cause your problem if it is actually faulty.
Thank you . So again I get code 23 when car is cold or ecu is in that strNge mode then when it gets warm it stops showing 23 then shows 24 and 14 . I think it's the small manifold leak on the turbo side causing issue ... Going to change the chts for the he'll of it this weekend
drdamm21 is offline  
Sponsored Links
Advertisement
 
post #24 of 46 (permalink) Old 09-19-2014, 03:36 AM
Senior Member
 
Mister_T's Avatar
 
Join Date: Apr 2005
Location: Melbourne Australia
Posts: 1,644
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Quote:
Originally Posted by drdamm21 View Post
So again I get code 23 when car is cold or ecu is in that strNge mode then when it gets warm it stops showing 23
23 should only go away by operating the throttle. It should not be influenced by temperature. Disconnect the throttle switch and see if it makes a difference.
Quote:
Originally Posted by drdamm21 View Post
then shows 24 and 14
24 should go away when the shifter is moved in and out of neutral.
14 should go away when the ECU gets a speed signal from the speedo.

Intake leaks are far more important than exhaust leaks. A boost leak test would be nice to verify the integrity of the intake system.

KHGZ31JAMG

Last edited by Mister_T; 09-19-2014 at 03:39 AM. Reason: Added info
Mister_T is offline  
post #25 of 46 (permalink) Old 09-21-2014, 01:42 PM Thread Starter
Member
 
Join Date: Dec 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Quote:
Originally Posted by Mister_T View Post
23 should only go away by operating the throttle. It should not be influenced by temperature. Disconnect the throttle switch and see if it makes a difference.

24 should go away when the shifter is moved in and out of neutral.
14 should go away when the ECU gets a speed signal from the speedo.

Intake leaks are far more important than exhaust leaks. A boost leak test would be nice to verify the integrity of the intake system.
Well maybe the real problem has shown it's face. Was driving and the whole car went to craps barley got home. Checked it out and looks like my altinator took a craps
drdamm21 is offline  
post #26 of 46 (permalink) Old 10-05-2014, 10:18 PM Thread Starter
Member
 
Join Date: Dec 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Update. So I just replaced my alternator and it runs and charges but will not hold a charge overnight then I noticed this battery looking thing sitting on the ground in my garage. Is this a required piece to the alternator and the reason why it's draining my battery?
drdamm21 is offline  
post #27 of 46 (permalink) Old 10-05-2014, 10:28 PM
Senior Member
 
Join Date: Feb 2010
Location: Oregon
Posts: 3,785
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 706 Post(s)
Quote:
Originally Posted by drdamm21 View Post
I noticed this battery looking thing sitting on the ground in my garage. Is this a required piece to the alternator and the reason why it's draining my battery?
Does it look a 9 volt, AAA, AA, A, C, D cell, or 6 volt dry cell (aka lantern) battery? Can't imagine that you found a full-size car battery looking thing on the garage floor. It wouldn't fit under the car.
pdx280 is offline  
post #28 of 46 (permalink) Old 10-05-2014, 10:43 PM Thread Starter
Member
 
Join Date: Dec 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Quote:
Originally Posted by pdx280 View Post
Does it look a 9 volt, AAA, AA, A, C, D cell, or 6 volt dry cell (aka lantern) battery? Can't imagine that you found a full-size car battery looking thing on the garage floor. It wouldn't fit under the car.
Lol sorry and yes it looks like a small c size battery with 2 wires coming out either side
drdamm21 is offline  
post #29 of 46 (permalink) Old 10-05-2014, 10:56 PM
Senior Member
 
Join Date: Feb 2010
Location: Oregon
Posts: 3,785
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 706 Post(s)
A small C or a tiny C? Sounds like a capacitor, aka condenser. Used on the alternator's charging wire to suppress electrical noise. Probably fell off when you changed the alternator. Not the problem source, although the fact that it fell off is a sign that other things might be falling apart.
pdx280 is offline  
post #30 of 46 (permalink) Old 10-05-2014, 11:01 PM Thread Starter
Member
 
Join Date: Dec 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Quote:
Originally Posted by drdamm21 View Post
Lol sorry and yes it looks like a small c size battery with 2 wires coming out either side
Only 1 wire coming out .
drdamm21 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
z31 MAF,ECCU swap useing the z31 harness maranaz 70-83 Tech Discussion Forum 0 03-22-2011 01:32 AM
strange noise strange motion stan260z 70-83 Tech Discussion Forum 2 10-19-2005 08:32 PM
-z31 topic- no help from z31 forum - just general engine miss fpr question? help 24ounce 70-83 Tech Discussion Forum 6 09-10-2005 01:45 AM
hesitation steve t 90-96 Tech Discussion Forum 2 06-01-2002 12:04 PM
Hesitation scoob1 90-96 Tech Discussion Forum 1 03-15-2002 09:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1