Fuel Injectors - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 09-08-2019, 03:57 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Fuel Injectors

Hello, brand new to the site, and the Z car world. I am bringing back to life a bone stock 1975 (01/75 build date) 280Z, 5-speed, AC car. So far I have refreshed the brakes, clutch and fuel tank. My question is what have most of you done with the injectors. The car was driven 3-4 times in fifteen years. I replaced all of the hoses and pump, but am curious if injectors are easily sourced, or if there is anyone that rebuilds them.

I am used to older Audis and Mustangs as restoration projects, but this car is so easy to work with. Thanks
RandyP1963 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-08-2019, 04:09 PM
Senior Member
 
pilgrim's Avatar
 
Join Date: Mar 2008
Location: Fort Collins, CO
Posts: 658
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
My suggestion is to send the injectors to an injector specialist, have them tested for flow, and use them if they pass. There are other threads with test sources, it's fairly common procedure.

You would be well advised to check the tank, and probably drop it and have it cleaned. While you're there, replace the hoses that connect to the tank.
pilgrim is offline  
post #3 of 8 (permalink) Old 09-08-2019, 04:38 PM
Senior Member
 
Join Date: Sep 2015
Location: Central FL
Posts: 977
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 228 Post(s)
Yep you can take them to a specialist, generally you are looking at about 20-25per. they should come back with new hoses attached as well.


Main thing is to replace ALL gas rubber hoses before you spring a leak and end up with a fire. On that same subject get a fire extinguisher and mount it somewhere easy to get at in the car.


check the water pump, remove the fan and clutch and see if there is any play in the shaft, you may want to just replace this if it looks old. Warning the water pump bolts are known to break, so you have to use any tricks you know to get them out safely.


Don't over tighten the fan belts, as it just stresses the pump bearings.


clearly new fluids, do some research on what oil to use. consider "flat tappets" not roller bearings on the valve train.


If you have only a single block for the fuse links under the hood, then be ready for a complete electrical loss IF the alternator shorts out. Mine did early on and took out the entire electrical system. Seems the fuse link that protects against a shorted alternator also provides power the fuse box. Bottom line is keep a few extra fuse links and know that if it happens, just disconnect the main alt power line to get you back on the road with a replacement fuse link. I think the later 280's added two more fuse links in a separate box, isolating the alt from the rest of the system.


I have a lot of videos on my 75, if you want to look at stuff I have worked on. Mine is all OE.
Dave WM on youtube.
Dave M is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-09-2019, 12:35 AM
Senior Member
 
Join Date: May 2009
Location: America's Auto Heartland
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
You know, if'n you're a little bit handy and get a charge out of the "self-sufficiency" part of wrangling cars, you could do a very credible job of grooming the injectors yourself. The process is pretty straight forward, and the FSM tells you all you need to know about their innards. Between that, a D-cell battery, some common chemicals, and a little creativity in pulling together a simple test stand, its not a tricky job.

Besides, it's the only reliable way to know that replacement is a matter of need (the only legit one being failure of an elect. trigger), and not just convenience.

Just a thought...



--------------------------
Keep 'em flying...

S.J.Szabo
-------------------------





ensys is offline  
post #5 of 8 (permalink) Old 09-10-2019, 09:31 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Dave M View Post
Yep you can take them to a specialist, generally you are looking at about 20-25per. they should come back with new hoses attached as well.


Main thing is to replace ALL gas rubber hoses before you spring a leak and end up with a fire. On that same subject get a fire extinguisher and mount it somewhere easy to get at in the car.


check the water pump, remove the fan and clutch and see if there is any play in the shaft, you may want to just replace this if it looks old. Warning the water pump bolts are known to break, so you have to use any tricks you know to get them out safely.


Don't over tighten the fan belts, as it just stresses the pump bearings.


clearly new fluids, do some research on what oil to use. consider "flat tappets" not roller bearings on the valve train.


If you have only a single block for the fuse links under the hood, then be ready for a complete electrical loss IF the alternator shorts out. Mine did early on and took out the entire electrical system. Seems the fuse link that protects against a shorted alternator also provides power the fuse box. Bottom line is keep a few extra fuse links and know that if it happens, just disconnect the main alt power line to get you back on the road with a replacement fuse link. I think the later 280's added two more fuse links in a separate box, isolating the alt from the rest of the system.


I have a lot of videos on my 75, if you want to look at stuff I have worked on. Mine is all OE.
Dave WM on youtube.
Thanks for the reply, I am removing the injectors this weekend. The tank is soaking in 15 gallons of white vinegar, and it is really cleaning out of all the rust. I have replaced or rebuilt the wheel cylinders and calipers. My big problem currently is the clutch is stuck, the pedal works, but it seems as if it bonded to the flywheel.

I will do research on the fusible links, it looks like someone replaced one of them previously, the cover is broken as well.
RandyP1963 is offline  
post #6 of 8 (permalink) Old 09-11-2019, 03:58 AM
Senior Member
 
Join Date: Sep 2006
Posts: 5,119
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
.02c
You may want to find something to neutralize the acid in the vinegar and flush it well. In any case clean steel will start to rust again unless it's protected.
As a somewhat related example: https://www.revzilla.com/common-trea...cycle-gas-tank
Do these tanks have a drain hole where you could insert a nozzle to fog the inside with a compatible rust preventative or light oil which could be flushed out before you fill it with gas?
Don't use gasoline as a spray to do a final flush as static will build up between the tank and spray pipe/nozzle...fiery.

zippityzda
dumbestone is offline  
post #7 of 8 (permalink) Old 09-11-2019, 01:26 PM
Senior Member
 
Join Date: Mar 2010
Posts: 619
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Two more cents on the injectors: I replaced ones on a '76 that I put back together after a long period of sitting (along with much of the same stuff mentioned in this thread). Restored to completely stock, the car ran but I could never get the idle smooth. Drove me crazy trying different stuff to smooth it out. Then read somewhere that the injectors I bougth were maybe not that great (might have even been on this forum). I had kept the originals, so sent them out for cleaning, and when I put them back in - obviously with all new O rings - the difference was remarkable. Car ran better and idled smooth. (I wish I could remember the brand but it's been a long time...)
Bottom line: if you do replace them with new or rebuilts, I would not go the cheap route. Bosche are the best.
Finally, if you want to get yours cleaned, you don't have to 'take' them anywhere to do that. You can send them. There are all kinds of places that do this, and most include new O-rings and those little plastic pintle tip protectors in the deal. (Mine did not come back with new hoses, tho.)
They can also tell you if they're spraying the same volume and pattern. I just checked on eBay and found one that charges $12 per injector, which is about what I paid 10-12 years ago. But even at twice that, it would be well worth the price (and wait) for me.
6shutr is offline  
post #8 of 8 (permalink) Old 09-15-2019, 08:22 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by 6shutr View Post
Two more cents on the injectors: I replaced ones on a '76 that I put back together after a long period of sitting (along with much of the same stuff mentioned in this thread). Restored to completely stock, the car ran but I could never get the idle smooth. Drove me crazy trying different stuff to smooth it out. Then read somewhere that the injectors I bougth were maybe not that great (might have even been on this forum). I had kept the originals, so sent them out for cleaning, and when I put them back in - obviously with all new O rings - the difference was remarkable. Car ran better and idled smooth. (I wish I could remember the brand but it's been a long time...)
Bottom line: if you do replace them with new or rebuilts, I would not go the cheap route. Bosche are the best.
Finally, if you want to get yours cleaned, you don't have to 'take' them anywhere to do that. You can send them. There are all kinds of places that do this, and most include new O-rings and those little plastic pintle tip protectors in the deal. (Mine did not come back with new hoses, tho.)
They can also tell you if they're spraying the same volume and pattern. I just checked on eBay and found one that charges $12 per injector, which is about what I paid 10-12 years ago. But even at twice that, it would be well worth the price (and wait) for me.
I just emptied the tank of all the vinegar, replaced it with baking soda and a gallon of water to neutralize the acid, then hooked up a heat gun to dry it out, followed by my sprayer with WD-40 to prevent flash rust. I had low expectations, but man it looks like new in there. Now on to purchasing a fuel pump. Is there a specific kind that is preferred? I see the Spectra brand is somewhat generic, main complaint is that the polarity is not marked, and the output is low.

I appreciate all of the help, still amazed at how simple these are to work on, really enjoying the experience.
RandyP1963 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1