1978 s30 Tach wiring help - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-22-2019, 09:00 AM Thread Starter
Junior Member
 
Shukize's Avatar
 
Join Date: Jun 2017
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
(Thread Starter)
1978 s30 Tach wiring help

Hi everyone, I have a 1978 280z that I've been working on for over a year now. In this time, I've got everything working from the drivetrain to the gauges (all except the tachometer), I usually drive it everyday. The tachometer is the only thing that doesn't work, and hasn't ever since I've had the car.

I removed the tachometer from the dash and tested voltage, it is a 3 wire tach. With key in ON position, Red/black wire going to peg has 10.95v, green has 10.96v, and the black is a GROUND I'm assuming.

I bought an aftermarket unit assuming the tachometer itself was bad. Installed it according to the wiring diagram. When I turn key to ON position nothing happens, when I start the car the aftermarket tach flashes for a split second, but doesn't come on, the needle does not move either.

Is there an in-depth diagram on the wiring of a 78 z, I'm mostly finding write ups on 240z's. Any help would be greatly appreciated, thank you so much.
Shukize is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-22-2019, 02:22 PM
Senior Member
 
Join Date: Jun 2016
Posts: 510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Quote:
Originally Posted by Shukize View Post
Hi everyone, I have a 1978 280z that I've been working on for over a year now. In this time, I've got everything working from the drivetrain to the gauges (all except the tachometer), I usually drive it everyday. The tachometer is the only thing that doesn't work, and hasn't ever since I've had the car.

I removed the tachometer from the dash and tested voltage, it is a 3 wire tach. With key in ON position, Red/black wire going to peg has 10.95v, green has 10.96v, and the black is a GROUND I'm assuming.

I bought an aftermarket unit assuming the tachometer itself was bad. Installed it according to the wiring diagram. When I turn key to ON position nothing happens, when I start the car the aftermarket tach flashes for a split second, but doesn't come on, the needle does not move either.

Is there an in-depth diagram on the wiring of a 78 z, I'm mostly finding write ups on 240z's. Any help would be greatly appreciated, thank you so much.
http://www.xenonzcar.com/s30/fsm.html

1978 280z - stock L28 engine - Dallas, TX
chaseincats is offline  
post #3 of 5 (permalink) Old 04-23-2019, 09:29 PM Thread Starter
Junior Member
 
Shukize's Avatar
 
Join Date: Jun 2017
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
(Thread Starter)
Thanks for the FSM. Figured it out if anyone else is having the issue.

Apparently the 40+ year old wiring just crapped out, I ran the Rev reading wire from the tach directly to the Negative post on the Ignition coil instead of using the stock wiring from the factory tachometer harness. I then ran the 12v constant power wire directly to the battery, the KEY ON wire to the the fuel pump relay, and GRND wire to a bolt on the chassis. Everything works perfectly and accurately now.
Shukize is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-23-2019, 11:03 PM
Senior Member
 
Join Date: Jun 2016
Posts: 510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Quote:
Originally Posted by Shukize View Post
Thanks for the FSM. Figured it out if anyone else is having the issue.

Apparently the 40+ year old wiring just crapped out, I ran the Rev reading wire from the tach directly to the Negative post on the Ignition coil instead of using the stock wiring from the factory tachometer harness. I then ran the 12v constant power wire directly to the battery, the KEY ON wire to the the fuel pump relay, and GRND wire to a bolt on the chassis. Everything works perfectly and accurately now.
glad to hear it!

1978 280z - stock L28 engine - Dallas, TX
chaseincats is offline  
post #5 of 5 (permalink) Old 04-29-2019, 05:53 PM
Senior Member
 
steve240Z73's Avatar
 
Join Date: Jun 2001
Location: Gainesville, GA
Posts: 2,428
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 71 Post(s)
In the factory wiring, the signal for the ground comes off the blue wire that runs to the transistor ignition unit. In between the blue wire and the tachometer is a 2200 Ohm 1/2 watt (I think it's 1/2 watt.) resistor.

Depending upon how "stock" someone has left the ignition, it could affect the tach. Also, the resistor can go bad.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- A great place to search for answers

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- the cheap source for FSMs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Look up S30 part numbers

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- My blog with some tech tips and pictures of my car-loving life

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Pictures from various car shows
steve240Z73 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
1978 S30, Cut-Out at WOT, Rich Condition Shukize 70-83 Tech Discussion Forum 13 03-02-2019 01:32 PM
1978 280Z Good Body, straight S30 chassis nishizawaS30 Cars for Sale: 1970-83 240Z, 260Z, 280Z, 280ZX 11 06-07-2016 11:07 PM
1978 S30 - done right YYZ Cars for Sale: 1970-83 240Z, 260Z, 280Z, 280ZX 11 03-08-2015 11:57 AM
1970 -1978 S30 240/260/280z jaimie25 WTB: Cars 1 04-08-2011 04:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1