Greenie Question - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 09-23-2018, 01:00 PM Thread Starter
Junior Member
 
Jcfernandez's Avatar
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Greenie Question

Hey there-
I'm brand new the the forum and probably a really long question but here goes.
1977 280zx was sitting garaged since 1992. I pick it up treated tank, placed in line filter, replaced injectors some rubber that was needed and fluids. Started right up and ran for 6 weeks OK. Didn't pass smog and I was told replace CAT. While stalling with that I was driving it once per week and one day it just lost power. Engine would idle, not respond to throttle, then died. Since then it will start occasionally but once it warms up and idle changes it dies. So I followed the book to trouble shoot the Control Unit. Got no continuity from Water temp sensor and Throttle control switch both at idle and full throttle. Am I on the right path? Should I replace those? I have spark and fuel so feels to me like air is my problem.
Jcfernandez is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-23-2018, 02:39 PM
Senior Member
 
black gold man's Avatar
 
Join Date: Jul 2009
Location: DETROIT
Posts: 3,882
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 157 Post(s)
Try this http://www.atlanticz.ca/zclub/techti...ons/index.html

http://www.atlanticz.ca/zclub/techtips/

BLACK GOLD MAN OF DETROIT 78 280Z 80ZX 10TH ANV 83 ZX 2+2 GL

MOTOR CITY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
black gold man is offline  
post #3 of 6 (permalink) Old 09-23-2018, 02:57 PM
Senior Member
 
freddy333's Avatar
 
Join Date: Feb 2009
Location: DC
Posts: 1,448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Could be one or more failed dropping resistors (small, metal box in the engine bay side wall just ahead of the clutch master). Refer to the testing procedures in the Factory Service Manual for your year (I don't believe there was a "ZX" in '77).
freddy333 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 09-23-2018, 04:21 PM
Senior Member
 
black gold man's Avatar
 
Join Date: Jul 2009
Location: DETROIT
Posts: 3,882
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 157 Post(s)
This is 78 fairlady It might have a build date of late 77. http://www.topcarrating.com/1978-nis...atsun-s130.php

BLACK GOLD MAN OF DETROIT 78 280Z 80ZX 10TH ANV 83 ZX 2+2 GL

MOTOR CITY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
black gold man is offline  
post #5 of 6 (permalink) Old 09-26-2018, 03:23 AM
Senior Member
 
Join Date: Jul 2013
Location: Palmetto, GA
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Garage
Great link...the labeled photos alone are a goldmine for me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Greg Reid is offline  
post #6 of 6 (permalink) Old 10-04-2018, 04:17 PM Thread Starter
Junior Member
 
Jcfernandez's Avatar
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the input! Turns out it was fuel pressure. New aftermarket FP and got the CAT replace per recommendation of mechanic friend because not passing COs for CA Smog. After new CAT retest and NO is high. Is that likely just too lean? Does the Carbon Filter have anything to do with that?
Jcfernandez is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
innercooler question/piping question SurfColorado 70-83 Tech Discussion Forum 7 08-10-2004 08:26 AM
question about the shaved p79 .080 and the z22 tensioner question mescalindreamz 70-83 Tech Discussion Forum 7 06-03-2004 10:29 PM
non Z question, but it's a general technical question. Please input. rnz 70-83 Tech Discussion Forum 4 05-31-2004 01:27 PM
a a rim question (NOT AN OFFSET QUESTION THOUGH) SurfColorado 70-83 Tech Discussion Forum 5 09-07-2003 01:50 AM
turbo question and rear question? Unknown User 70-83 Tech Discussion Forum 3 03-13-2001 09:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1